Community discussions

MUM Europe 2020
 
pizzulicchio
newbie
Topic Author
Posts: 26
Joined: Mon Feb 13, 2012 3:35 pm

RouteOS 6.0 beta3 Missing SNMP OID

Tue Sep 11, 2012 3:19 pm

Good day.
After upgraded to 6.0beta 3 i'm notbe able to retrive some information from my RB-SXTwith SNMP.

[admin@MikroTik - Samu] > interface wireless print oid
0 tx-rate=.1.3.6.1.4.1.14988.1.1.1.3.1.2.2
rx-rate=.1.3.6.1.4.1.14988.1.1.1.3.1.3.2
ssid=.1.3.6.1.4.1.14988.1.1.1.3.1.4.2 bssid=.1.3.6.1.4.1.14988.1.1.1.3.1.5.2
client-count=.1.3.6.1.4.1.14988.1.1.1.3.1.6.2
frequency=.1.3.6.1.4.1.14988.1.1.1.3.1.7.2
band=.1.3.6.1.4.1.14988.1.1.1.3.1.8.2
noise-floor=.1.3.6.1.4.1.14988.1.1.1.3.1.9.2
overall-ccq=.1.3.6.1.4.1.14988.1.1.1.3.1.10.2

all these oid are no more queryable:

Some example below:
snmpwalk -c public -v1 192.168.1.200 .1.3.6.1.4.1.14988.1.1.1.3.1.6.2
End of MIB

snmpwalk -c public -v1 192.168.1.200 .1.3.6.1.4.1.14988.1.1.1.3.1.5.2
End of MIB

There is no problem with these oid:

[admin@MikroTik - Samu] > system health print oid
active-fan: .1.3.6.1.4.1.14988.1.1.3.9.0
voltage: .1.3.6.1.4.1.14988.1.1.3.8.0
temperature: .1.3.6.1.4.1.14988.1.1.3.10.0
processor-temperature: .1.3.6.1.4.1.14988.1.1.3.11.0

Can anyone confirm?
 
pizzulicchio
newbie
Topic Author
Posts: 26
Joined: Mon Feb 13, 2012 3:35 pm

Re: RouteOS 6.0 beta3 Missing SNMP OID

Mon Sep 17, 2012 12:47 pm

Will be corrected in v6.0beta4 or any other future release?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RouteOS 6.0 beta3 Missing SNMP OID

Mon Sep 17, 2012 1:25 pm

can confirm, will look into it.
 
pizzulicchio
newbie
Topic Author
Posts: 26
Joined: Mon Feb 13, 2012 3:35 pm

Re: RouteOS 6.0 rc1 Missing SNMP OID

Fri Sep 21, 2012 3:17 pm

I have just updated the firmware to my couple of Rb-SXT ( Version 6.0rc1 ) but the problem remains...
Missing response for Overall-CCQ, TX/RX rate alignament, DB link etc etc... from snmpwalk...
Waiting for another firmware release... :(
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RouteOS 6.0 beta3 Missing SNMP OID

Fri Sep 21, 2012 3:29 pm

changes will be introduced in later release. as you can see only on 17th missing oids where noted and on 21st release of version rc1
 
pizzulicchio
newbie
Topic Author
Posts: 26
Joined: Mon Feb 13, 2012 3:35 pm

Re: RouteOS 6.0 beta3 Missing SNMP OID

Fri Sep 21, 2012 5:27 pm

Thank you for your quick reply.
I have appreciated your work! i can wait, it's only a notification. I know that router os 6 it's not for production environment at the moment! :-)
 
Rivera
Member Candidate
Member Candidate
Posts: 105
Joined: Thu Jul 21, 2011 7:42 pm

Re: RouteOS 6.0 beta3 Missing SNMP OID

Wed Oct 03, 2012 2:10 pm

Can't grab interfaces on 6.0rc1
lex@exile > snmpwalk -v2c -c lexcomt 192.168.69.1
iso.3.6.1.2.1.1.1.0 = STRING: "RouterOS RB493G"
iso.3.6.1.2.1.1.2.0 = OID: iso.3.6.1.4.1.14988.1
iso.3.6.1.2.1.1.3.0 = Timeticks: (24436800) 2 days, 19:52:48.00
iso.3.6.1.2.1.1.4.0 = STRING: "mail here"
iso.3.6.1.2.1.1.5.0 = STRING: "hostname"
iso.3.6.1.2.1.1.6.0 = STRING: "location"
iso.3.6.1.2.1.1.7.0 = INTEGER: 78
iso.3.6.1.2.1.2.1.0 = INTEGER: 20
iso.3.6.1.2.1.2.2.1.1.42 = INTEGER: 42
iso.3.6.1.2.1.2.2.1.1.41 = INTEGER: 41
Error: OID not increasing: iso.3.6.1.2.1.2.2.1.1.42
>= iso.3.6.1.2.1.2.2.1.1.41

UPD: i see it reports MIBs out of order. Any way to fix that?
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: RouteOS 6.0 beta3 Missing SNMP OID

Wed Oct 03, 2012 3:33 pm

it will be resolved in future release, as patches for this did not made into 6.0rc1
 
Rivera
Member Candidate
Member Candidate
Posts: 105
Joined: Thu Jul 21, 2011 7:42 pm

Re: RouteOS 6.0 beta3 Missing SNMP OID

Wed Oct 03, 2012 4:18 pm

Thanks. Currently "fixed" with snmpbulkwalk -Cc, some digits messed up, but at least it shows interfaces usage.
 
pizzulicchio
newbie
Topic Author
Posts: 26
Joined: Mon Feb 13, 2012 3:35 pm

Re: RouteOS 6.0 beta3 Missing SNMP OID

Mon Nov 12, 2012 2:51 pm

even with 6.0 RC3 the problema remain:

*) fixed problem - MetaROUTERs did not work on RB2011s;
*) fixed problem - Realtek 1Gbit ethernet cards did not work;
*) added "/ip settings" menu with following settings:
ip-forward, send-redirects, accept-source-route, accept-redirects,
secure-redirects, rp-filter, tcp-syncookies;
*) fix some ipv6 firewall matchers;
*) improved performance for eoip,eoipv6,gre,gre6 tunnels, especially on multi core;
*) /queue tree entries with parent=global are performed separately from /queue simple and before /queue simple;
*) snmp - fixed missing OIDs;

[admin@MikroTik - Samu] > interface wireless print oid
0 tx-rate=.1.3.6.1.4.1.14988.1.1.1.3.1.2.2
rx-rate=.1.3.6.1.4.1.14988.1.1.1.3.1.3.2
ssid=.1.3.6.1.4.1.14988.1.1.1.3.1.4.2 bssid=.1.3.6.1.4.1.14988.1.1.1.3.1.5.2
client-count=.1.3.6.1.4.1.14988.1.1.1.3.1.6.2
frequency=.1.3.6.1.4.1.14988.1.1.1.3.1.7.2
band=.1.3.6.1.4.1.14988.1.1.1.3.1.8.2
noise-floor=.1.3.6.1.4.1.14988.1.1.1.3.1.9.2
overall-ccq=.1.3.6.1.4.1.14988.1.1.1.3.1.10.2

no response for those oids...



SORRY [ERRATA CORRIGE]

I have had to reassign the wireless interface because it was disabled after the upgrade.

All is working fine!

Who is online

Users browsing this forum: enzain, ERWZA, macsrwe, markphelan, MSN [Bot], mustafan, omidkosari and 131 guests