Community discussions

MikroTik App
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

simple queues understanding problem

Tue Nov 13, 2012 10:42 pm

Hi!

I've installed 6.0rc2 to play with the simple rules, but I don't understand something

My test setup is a mikrotik with a DSL uplink and multiple VLANs hind it. I want to shape the traffic from and to the Internet but not between the VLANs.

I therefore added following queue
/queue simple add max-limit=6100k/450k name=queueDsl queue=wireless-default/wireless-default target=pptpDslInternet
it does match the traffic which goes from and to my server. Winbox shows it. I now add e.g. a mangle rule to match some traffic more specify traffic.
/ip firewall mangle
     add action=mark-connection chain=forward comment="mark connection incomming from server" connection-state=new dst-address=10.x.x.6 in-interface=pptpDslInternet new-connection-mark=connectionServer
     add action=mark-connection chain=forward comment="mark connection outgoing from server" connection-state=new new-connection-mark=connectionServer out-interface=pptpDslInternet src-address=10.x.x.6
     add action=mark-packet chain=forward comment="now mark the packet" connection-mark=connectionServer new-packet-mark=packetServer passthrough=no
if I look with
/ip firewall mangle print stats
I see the traffic matching. But as soon as I add following simple queue, the parent and client queue rule don't match any traffic
/queue simple add limit-at=500k/50k max-limit=6100k/450k name=queueServer packet-marks=packetServer parent=queueDsl
If I disable the client rule it works again. Why? What is my misunderstanding with the new simple queues (and possible the old ones)?

I thoughed the only requirement for a client queue is that the parent queue also does match the traffic (otherwise it doesn't see it) and the new GLOBAL is after post-routing so marking in FORWARD should be ok?

Thx for your help.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1734
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: simple queues understanding problem

Wed Nov 14, 2012 5:54 pm

1) your simple queue don't have target specified, so it doesn't know where is upload and where is download, so specify target interface or IP

2) there are some kind of parent queue there - in simple queues parent must be able to capture all traffic that child will need or else child will not get to that traffic.

3) upgrade to 6.0rc3
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

Re: simple queues understanding problem

Wed Nov 14, 2012 6:05 pm

thx for your answer

1. I had that already, did remove it as I thought thats maybe the problem .. but I will reinsert it
2. all traffic which the child should get, goes through the DSL Uplink or is there some error in the config so that's not the case?
3. ok
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

Re: simple queues understanding problem

Wed Nov 14, 2012 11:24 pm

Its a bug ... it works in rc2 and rc3 until the pptp connection reconnects than it stops working .. I reported it to mikrotik.
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

Re: simple queues understanding problem

Sun Nov 25, 2012 9:26 am

Mikrotik reported back. They could reproduce the bug.
 
robertpenz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 80
Joined: Mon Oct 10, 2011 8:41 am

Re: simple queues understanding problem

Fri Nov 30, 2012 9:47 pm

Fixed in rc4

Who is online

Users browsing this forum: sindy and 139 guests