Community discussions

 
Deac
newbie
Topic Author
Posts: 33
Joined: Tue Feb 12, 2013 7:21 am

Wireless bonding technique.

Fri Mar 15, 2013 11:56 am

I have repeatedly seen a question about wireless cards bonding. Usually offered tunneling scheme(like EoIP) works quite well but dramatically decreases performance.
In my practice I use aggregation of wireless interfaces through VLAN.

General principles set out below:
RF_VLAN_Bonding.jpg
AP side settings.
1. Create bridge
/interface bridge
add l2mtu=1526 name=BasicBridge#1
2. Prepare wireless interfaces in bridge mode with different SSID and freq.
/interface wireless
set 0 band=5ghz-onlyn disabled=no disconnect-timeout=15s frequency=5260 \
    frequency-mode=superchannel hide-ssid=yes ht-rxchains=0,1 ht-txchains=0,1 \
    hw-protection-mode=rts-cts l2mtu=2290 mode=bridge name=R52n-M#1 \
    nv2-preshared-key=Channel#1_key nv2-security=enabled \
    periodic-calibration=enabled periodic-calibration-interval=5 radio-name=\
    AP_R52n-M#1 scan-list=5200-5600 ssid=Channel#1 wds-mode=\
    dynamic wireless-protocol=nv2
set 1 band=5ghz-onlyn disabled=no disconnect-timeout=15s frequency=5300 \
    frequency-mode=superchannel hide-ssid=yes ht-rxchains=0,1 ht-txchains=0,1 \
    hw-protection-mode=rts-cts l2mtu=2290 mode=bridge name=R52n-M#2 \
    nv2-preshared-key=Channel#2_key nv2-security=enabled \
    periodic-calibration=enabled periodic-calibration-interval=5 radio-name=\
    AP_R52n-M#2 scan-list=5200-5600 ssid=Channel#2 wds-mode=\
    dynamic wireless-protocol=nv2
3. Create VLAN with different tags and bind them to an every of wireless interfaces.
/interface vlan
add interface=R52n-M#1 l2mtu=2286 name=RF_VLAN#1 vlan-id=501
add interface=R52n-M#2 l2mtu=2286 name=RF_VLAN#2 vlan-id=502
4. Create a bonding interface and put the previously created VLAN here.
/interface bonding
add arp-interval=500ms arp-ip-targets=192.168.191.2 link-monitoring=arp mtu=\
    1526 name=RF_Bonding#1 slaves=RF_VLAN#1,RF_VLAN#2
5. Put ethernet and bonding interface into bridge.
/interface bridge port
add bridge=BasicBridge#1 interface=ether1
add bridge=BasicBridge#1 interface=RF_Bonding#1
6. Add IP address for management and bind it to the bridge. Add IP address for link monitoring and bind it to the bonding.
/ip address
add address=192.168.112.1/24 interface=BasicBridge#1
add address=192.168.191.1/30 interface=RF_Bonding#1
STA side settings.
Same as AP except wireless mode and IP addresses.
/interface bridge
add l2mtu=1526 name=BasicBridge#1

/interface wireless
set 0 band=5ghz-onlyn channel-width=20/40mhz-ht-above disabled=no \
    disconnect-timeout=15s frequency=5260 frequency-mode=superchannel \
    ht-rxchains=0,1 ht-txchains=0,1 hw-protection-mode=rts-cts l2mtu=2290 \
    mode=station-bridge name=R52n-M#1 nv2-preshared-key=\
    Channel#1_key nv2-security=enabled \
    periodic-calibration=enabled periodic-calibration-interval=5 radio-name=\
    STA_R52n-M#1 scan-list=5200-5600 ssid=Channel#1 wds-mode=\
    static wireless-protocol=nv2
set 1 band=5ghz-onlyn channel-width=20/40mhz-ht-above disabled=no \
    disconnect-timeout=15s frequency=5300 frequency-mode=superchannel \
    ht-rxchains=0,1 ht-txchains=0,1 hw-protection-mode=rts-cts l2mtu=2290 \
    mode=station-bridge name=R52n-M#2 nv2-preshared-key=\
    Channel#2_key nv2-security=enabled \
    periodic-calibration=enabled periodic-calibration-interval=5 radio-name=\
    STA_R52n-M#2 scan-list=5200-5600 ssid=Channel#2 wds-mode=\
    static wireless-protocol=nv2

/interface vlan
add interface=R52n-M#1 l2mtu=2286 name=RF_VLAN#1 vlan-id=501
add interface=R52n-M#2 l2mtu=2286 name=RF_VLAN#2 vlan-id=502

/interface bonding
add arp-interval=500ms arp-ip-targets=192.168.191.1 link-monitoring=arp mtu=\
    1526 name=RF_Bonding#1 slaves=RF_VLAN#1,RF_VLAN#2

/interface bridge port
add bridge=BasicBridge#1 interface=ether1
add bridge=BasicBridge#1 interface=RF_Bonding#1

/ip address
add address=192.168.112.2/24 interface=BasicBridge#1
add address=192.168.191.2/30 interface=RF_Bonding#1
In result we have the aggregate wireless bridge with kept transparency and performance:
Aggregate_RF_bridge.JPG
You do not have the required permissions to view the files attached to this post.
 
hipro5
Member Candidate
Member Candidate
Posts: 161
Joined: Sat Feb 09, 2013 11:48 am
Location: Hellas (Greece)

Re: Wireless bonding technique.

Mon Mar 18, 2013 5:04 pm

One of the MOST USEFULL trheads in here.
Thanks a LOT M8. :)
 
abcwarbot
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun Apr 25, 2010 9:23 pm

Re: Wireless bonding technique.

Thu Aug 01, 2013 2:45 am

Hi Deac,

Little help here. I have same setup but balance-rr is not supporting both mini-pci at the time. Even is one or the other.
Maybe you can give me a push. My network is full bridge.



Thanx in advance.
 
Deac
newbie
Topic Author
Posts: 33
Joined: Tue Feb 12, 2013 7:21 am

Re: Wireless bonding technique.

Thu Aug 01, 2013 1:53 pm

In this scheme bonding works through VLAN iface instead of HW iface.
P.S. This technique is inapplicable for ROS v6.x series. Coz bonding still broken.
 
abcwarbot
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun Apr 25, 2010 9:23 pm

Re: Wireless bonding technique.

Thu Aug 01, 2013 9:02 pm

Hi,

Thnx for answer. This is not working for me.
Using 2 XR5 at each side and RB433H ROS 5.25.

When set this conf, my wlans only get about 700k each direction. Typical speed when not bonding is 22M.

Any suggestion.?



Best regards
 
Deac
newbie
Topic Author
Posts: 33
Joined: Tue Feb 12, 2013 7:21 am

Re: Wireless bonding technique.

Thu Aug 01, 2013 10:10 pm

UBNT XR5 isn't 802.11n card and has only one chain.
I guess you're replacing 'band=5ghz-onlyn' with 'band=5ghz-a' in this config?
If yes then try 'nstreme' or '802.11' wireless protocol instead 'nv2'.
 
abcwarbot
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun Apr 25, 2010 9:23 pm

Re: Wireless bonding technique.

Fri Aug 02, 2013 8:32 am

Hi Deac,

I have no success, with nstreme all variations nor 802.11.
Can you tell me if you set service tag on VLAN.?
Have you tried same config on 5.25 boxes.?
Were you able to run Bandwidth test UDP over it..?




Best regards
 
Deac
newbie
Topic Author
Posts: 33
Joined: Tue Feb 12, 2013 7:21 am

Re: Wireless bonding technique.

Fri Aug 02, 2013 5:38 pm

I have no XR5 but I set 'A' band on R52n-M and use only one chain.

Test throughput using first leg only:
VLAN_bonding_first_leg.jpg
Test throughput using second leg only:
VLAN_bonding_second_leg.jpg
Summarize throughput using both leg:
VLAN_bonding_both_leg.jpg
ROS v5.25 is used.
You do not have the required permissions to view the files attached to this post.
 
abcwarbot
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun Apr 25, 2010 9:23 pm

Re: Wireless bonding technique.

Fri Aug 02, 2013 8:50 pm

Hi,

Thanks for that awesome testing answer.
I did some Btest, when only 5M traffic is load balance tru links. When 10M balance is load balance tru links for a while and then suddenly balance crash.

So, final word XR5 not compatible with bonding..?



Best regards
 
Deac
newbie
Topic Author
Posts: 33
Joined: Tue Feb 12, 2013 7:21 am

Re: Wireless bonding technique.

Fri Aug 02, 2013 10:12 pm

I didn't have XR5 for tests and I haven't 'word' about it.
Sorry.

My vote for native equipment.
Like R52n-M, R52Hn, etc
 
angboontiong
Forum Guru
Forum Guru
Posts: 1115
Joined: Fri Jan 16, 2009 9:59 am

Re: Wireless bonding technique.

Fri Aug 02, 2013 10:23 pm

if let say one link can carry 10Mbps, the other one can carry 20Mbps...
which will be the limitation for it???

10M/ 20M/ or ???
 
Deac
newbie
Topic Author
Posts: 33
Joined: Tue Feb 12, 2013 7:21 am

Re: Wireless bonding technique.

Fri Aug 02, 2013 10:31 pm

Wrong way.
'Balance Round-Robin' works ONLY with links who have same throughput.

If you have asymmetric links then you need other balance mechanism.
Like 'alb' or 'tlb'.
 
abcwarbot
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun Apr 25, 2010 9:23 pm

Re: Wireless bonding technique.

Fri Aug 02, 2013 10:54 pm

Hi Deac,

Gonna try Mikrotik mini-pcis. I'll let you know.



Bests.!
 
abcwarbot
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Sun Apr 25, 2010 9:23 pm

Re: Wireless bonding technique.

Fri Aug 02, 2013 10:56 pm

Wrong way.
'Balance Round-Robin' works ONLY with links who have same throughput.

If you have asymmetric links then you need other balance mechanism.
Like 'alb' or 'tlb'.
AFAIK your gonna get twice the slower link.
Correct if im wrong.
 
Deac
newbie
Topic Author
Posts: 33
Joined: Tue Feb 12, 2013 7:21 am

Re: Wireless bonding technique.

Sat Aug 03, 2013 12:22 am

Nope.
'Round-Robin' doesn't work with asymmetrical links because it breaks the packets order.
 
kiwistag
just joined
Posts: 11
Joined: Mon Jun 24, 2013 12:53 am
Location: New Zealand

Re: Wireless bonding technique.

Tue Aug 06, 2013 4:56 am

Would there be a way to do it simpler with say a RB951G at each end with 2x Ubiquiti AirMax's acting as the bridging A.P's/clients?
Our current setup is Active-Backup but balance-rr or -alb would be better.
 
User avatar
juanvi
Member Candidate
Member Candidate
Posts: 164
Joined: Mon May 05, 2014 6:55 pm
Location: SPAIN

Re: Wireless bonding technique.

Fri Mar 27, 2015 11:41 am

In this scheme bonding works through VLAN iface instead of HW iface.
P.S. This technique is inapplicable for ROS v6.x series. Coz bonding still broken.
Hi, thanks for the info. I'm running this setup in Ros 6.28.rc17 and performs better with vlans tan without it, but I'm having issues.

First of all i have 2 ubiquiti wireless 2.4 links performing +-140Mbps each (receiving) when working alone. SSID and channel are different: One uses firs 40Mhz of the available spectrum a the other the rest 40MHz.

When I put the two links (Vlan interfaces) in the bonding the Bandwith UDP test increases to 190Mbps in one direction instead of the 280 expected.

Can be disturbing one radio the other? Is the bonding broken as you say? I'm looking for double bandwith for backup purposes.

Thanks in advance
¡vʞvdnX puv ···SOɹǝʇnoɹ ʞıʇoɹʞıW oʇ sʞuvHʇ

Who is online

Users browsing this forum: No registered users and 16 guests