Community discussions

MikroTik App
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 71
Joined: Wed Apr 03, 2013 6:52 pm

Using queues properly...

Thu Apr 25, 2013 3:45 am

I'm coming from pfSense, which I know I can't keep comparing RouterOS to. Traffic Shaping is a breeze in pfSense, even if you DONT use the wizards.

I'm having a nightmare getting queues to behave the way I want on RouterOS. Its just not flexible or smart enough it seems. I'm on a RB2011UAS-RM, using eth1 for gateway, eth2 for the only client, btw.

On pfSense I have HFSC queues setup that I can run right up to the limit of 30Mbps before the cable company's limiter kicks in (and increases pings to over 300ms while it chokes you back). But pfSense also lets it all float nicely between users and I never have variation, it goes straight up to 30Mbps and sticks, its consistent in that it never trips the limiters. Its just rock solid no problems and my pings to the far end of the cable company's router stay nicely between 7 and 13 ms..

On RouterOS I have a simple queue to start with (as I only have 1 client hooked up to it) and if I set no bursts, just a limit at 30Mbps I get an oscillation between 25 and 32Mbps that happens over what looks like 5 seconds (granted the average is 30M, but those peaks above 30 trigger the timer on the cable end).. The cable modem will burst to 50Mbps for 10 seconds then clamps to 30Mbps but any traffic over the 30Mbps in 30 seconds keeps the timer running, I never want to trip into that burst area as when the cable company clamps down it makes the pings jump.

So I starting thinking under RouterOS, 30M must equal something different then 30M on pfsense. So I try 15M since I KNOW that won't trip the limiter. But I don't get consistent download speeds, I get a variation over about 10 seconds between 12M and 20M which average to around 15M.

Now: How do I get rid of the variability? Should I set the limit at the "Max Limit" part of the queue page, or down about halfway at the "Limit at" part of the queue page? I have "Burst Time" set at "0" so that logically should be disabled. Or is the queue system in RouterOS just doing its best already? I'd hate to have to sacrifice 2+Mbps (to keep it from triggering the WAN's limiter) just because RouterOS can't throttle right..

If it weren't for trying to move to something running off much lower power, I'd have no more interest in messing with RouterBoard products because RouterOS seems SOOOOOO far behind pfSense. I'm just about fed up with all the webfig bugs (being an RC some of them should have been worked out in BETA) and now it can't seem to do the simple stuff that I need that are simple as cake in pfSense...
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sun Jan 29, 2012 6:32 pm

Re: Using queues properly...

Thu Apr 25, 2013 5:24 am

I came from pfsense and loved the simple web interface and that everything pretty much just worked.

I run a wisp and couldn't if it wasn't for mikrotik. I've learned to make it do what I need to and now I love it.

My only suggestion at this point is,
If you're on windows, use winbox.
I hate the web fig interface..

Who is online

Users browsing this forum: dioeyandika and 39 guests