Community discussions

 
wildbill442
Forum Guru
Forum Guru
Topic Author
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

RFC 3021 and ROS

Thu Mar 16, 2006 3:33 am

Does RouterOS support RFC3021 for point to point links? (31bit masks)
 
eflanery
Member
Member
Posts: 382
Joined: Fri May 28, 2004 10:11 pm
Location: Moscow, ID
Contact:

Thu Mar 16, 2006 9:04 pm

I don't know, never tried it. But, MT does support an even more efficient method.

You can just use /32s, the addresses don't have to be adjacent, and they can be reused on multiple interfaces.

i.e.:

router1
/ip address add address=1.1.1.1/32 network=2.2.2.2 interface=to-router2
/ip address add address=1.1.1.1/32 network=3.3.3.3 interface=to-router3
router2
/ip address add address=2.2.2.2/32 network=1.1.1.1 interface=to-router1
/ip address add address=2.2.2.2/32 network=3.3.3.3 interface=to-router3
router3
/ip address add address=3.3.3.3/32 network=1.1.1.1 interface=to-router1
/ip address add address=3.3.3.3/32 network=2.2.2.2 interface=to-router2
3 point-to-points, using only 3 addresses; /31s would require 6, and they would need to be in pairs.

With more links, it becomes drastically more efficient.

--Eric
 
User avatar
mag
Member
Member
Posts: 378
Joined: Thu Jul 01, 2004 12:32 pm
Location: Cologne, NRW, Germany
Contact:

Fri Mar 17, 2006 9:32 am

good! i always missed some kind of "unnumbered" connection.
this should be a perfect replacement.
(it's not mentioned in the manual particularly, is it?;-)
 
User avatar
Eugene
Forum Veteran
Forum Veteran
Posts: 993
Joined: Mon May 31, 2004 5:06 pm
Location: Cranfield, UK

Fri Mar 17, 2006 5:00 pm

And you can use OSPF on these links to. Just don't forget to specify the interface as being point-to-point.
Tout individu a droit à la vie, à la liberté et à la sûreté de sa personne.
 
eflanery
Member
Member
Posts: 382
Joined: Fri May 28, 2004 10:11 pm
Location: Moscow, ID
Contact:

Fri Mar 17, 2006 9:12 pm

And you can use OSPF on these links to. Just don't forget to specify the interface as being point-to-point.
Or, on older (2.8) systems where that isn't an option, encapsulate it in a PPP link of some sort (l2tp, etc...), works like a charm (usually).

--Eric
 
wildbill442
Forum Guru
Forum Guru
Topic Author
Posts: 1050
Joined: Wed Dec 08, 2004 7:29 am
Location: Sacramento, CA

Sat Mar 18, 2006 2:54 am

And you can use OSPF on these links to. Just don't forget to specify the interface as being point-to-point.
I didn't think of that, and I do plan on implementing OSPF. Thanks..

Who is online

Users browsing this forum: sashoatanasow and 96 guests