Community discussions

MikroTik App
 
mgrabar
just joined
Topic Author
Posts: 14
Joined: Sat Sep 25, 2010 10:06 am

Matching PPP protocol type with ROS

Tue Jul 30, 2013 3:46 pm

In order to increase PPPoE session stability over noisy wireless links, I am trying to setup a simple mangle and/or bridging filter rules that would mark PPPoE control packets with set priority 7.
I am using ROS 6.1 with nv2 proprietary protocol frame-priority QoS feature. Feature is tested and it’s working just fine.

Now, let’s proceed to my problem.

In order to increase reliability of PPPoE session, I need to match the following packets:
1. Whole PPPoE-Discovery protocol (Ethertype 0x8863)
2. Only part of PPPoE-Session protocol (Ethertype 0x8864)

I am stuck in matching that “part” of 0x8864 protocol. Basically, I need to match packets from PPP LCP, PPP IPCP and PPP CHAP protocols. Especially the PPP LCP protocol which maintains the connection by using small keepalive packets.

Some packets will originate from the router itself (output) and some packets will be pass through the router (forward). Some packets can be matched by bridge filter while others can be matched by IP firewall mangle rules. It really doesn’t matter. Direction also doesn’t matter to me right now. The only thing that matters is that someone show me how can I match PPP protocol values.

Please take a moment to review attached PDF.
I have explained everything in there.

p.s. Here is what I’ve got so far (it is bad because the second rule matches the whole PPP protocol):
/interface bridge filter
# PADI, PADO, PADR, PADS, PADT
add chain=forward action=set-priority new-priority=7 passthrough=yes mac-protocol=pppoe-discovery 
# PPP LCP, PPP CHAP, PPP IPCP – BAD RULE of course, matches everything..
add chain=forward action=set-priority new-priority=7 passthrough=yes mac-protocol=pppoe
Thank you.
You do not have the required permissions to view the files attached to this post.
 
n21roadie
Forum Guru
Forum Guru
Posts: 1909
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Matching PPP protocol type with ROS

Tue Jul 30, 2013 5:38 pm

........over noisy wireless links..........
I use AP's with PPPoE and have no issue with noise, but I am curious to find out more about "noisy wireless links"
Are we talking about wireless disconnections - Control frame timeout, etc
N21roadie,
Network 100% MT for Now?
 
mgrabar
just joined
Topic Author
Posts: 14
Joined: Sat Sep 25, 2010 10:06 am

Re: Matching PPP protocol type with ROS

Tue Jul 30, 2013 5:52 pm

What I’ve meant to say is a “busy wireless links”.

I have configured QoS for VoIP traffic which is doing a great job (since version 6.0+ because we are doing station-bridge mode in NV2). Except, when the link is really busy and on low bandwidth, the customer starts VoIP call and PPPoE session becomes unstable. Yeah, funny. I have compared a number of Port-Error packets before and after VoIP QoS implementation on test deployment and they have doubled (which is actually not good).

We can chat on a side about this, but I would be really grateful if we could stick to my original questions regarding packet matching.
 
marekm
Member Candidate
Member Candidate
Posts: 244
Joined: Tue Feb 01, 2011 11:27 pm

Re: Matching PPP protocol type with ROS

Fri Jun 05, 2015 3:02 am

Found this thread from 2 years ago, and I'm interested in this too - would like to give higher L2 (802.1p) priority to PPPoE LCP frames to reduce number of disconnects, and possibly also to PPPoE data traffic of selected customers (based on RADIUS). Has anything improved in this area in the current RouterOS releases?
 
marekm
Member Candidate
Member Candidate
Posts: 244
Joined: Tue Feb 01, 2011 11:27 pm

Re: Matching PPP protocol type with ROS

Tue Jul 07, 2020 6:44 pm

Bump after 5 years.
I'd like to give higher priority to these specific PPPoE control frames passing through RouterOS bridges (wireless CPE in upload direction which also does VLAN tagging, wireless AP in download direction which just passes tagged VLANs as is from the PPPoE server). Download direction could also be done on CRS328-24P-4S+RM which powers the APs - if it can be done while still keeping bridge HW offload enabled.
The PPPoE discovery (ethertype 0x8863) part is easy, but the more difficult one (ethertype 0x8864 and PPPoE LCP protocol as opposed to data) is more important.
Is it possible today?
Cisco describes this feature here - https://www.cisco.com/c/en/us/td/docs/i ... pppoe.html
 
pe1chl
Forum Guru
Forum Guru
Posts: 7044
Joined: Mon Jun 08, 2015 12:09 pm

Re: Matching PPP protocol type with ROS

Tue Jul 07, 2020 9:07 pm

Maybe you would be helped by the addtion of the "u32" matcher to the firewall matching rules, this exists in Linux and can extract arbitrary fields from packet headers and compare them to fixed values. This could then be used in a mangle rule to set the priority.

Who is online

Users browsing this forum: stank1978, volvox, winagain and 37 guests