Community discussions

MikroTik App
 
kazibole
just joined
Topic Author
Posts: 7
Joined: Fri Jun 24, 2011 6:04 am

VLAN 0 and 802.1p tag

Sun Sep 08, 2013 11:44 pm

I need to tag outgoing packets with a VLAN ID of 0 and a 802.1p tag of 3. The GUI or CLI won't let me create a VLAN with ID of 0. When I create a bridge filter rule to "set priority" on outgoing packets, I see packets hitting the rule but no priority tag is applied, I am assuming because there is no VLAN tag. Any ideas would be greatly appreciated.
 
CelticComms
Forum Guru
Forum Guru
Posts: 1766
Joined: Wed May 02, 2012 5:48 am

Re: VLAN 0 and 802.1p tag

Mon Sep 09, 2013 7:29 am

VLAN ID 0 is reserved under the 802.1q standard which is probably why the RouterOS implementation doesn't permit it.
Interlynx | Networking and Information Security Consultants & Trainers | Email: routerlynx@gmail.com
BGP | EIGRP | OSPF | MPLS | Firewall | VPN | IPsec | Multicast | QOS | IPv4/6 | STP | VLAN | PON | AE | M2M | and more!

 
kazibole
just joined
Topic Author
Posts: 7
Joined: Fri Jun 24, 2011 6:04 am

Re: VLAN 0 and 802.1p tag

Mon Sep 09, 2013 8:16 pm

Thank you for your response, that makes sense why I cannot directly use VLAN 0. The packets that I sniffed from the router I need to emulate indeed has the VLAN tag set to 0 and a priority tag set. This is a blurb I found elsewhere on the internet:
Of the 4096 possible VIDs, a VID of 0 is used to identify priority frames
VLAN 0 packets should carry an 802.1p priority but otherwise should be handled as untagged packets
So I suppose my question is, am I doing something wrong with my bridge filter to apply a priority tag to an untagged packet, or is the Mikrotik router not applying the priority tag because there is no vlan tag?
 
User avatar
JJCinAZ
Member
Member
Posts: 475
Joined: Fri Oct 22, 2004 8:03 am
Location: Tucson, AZ
Contact:

Re: VLAN 0 and 802.1p tag

Wed Sep 11, 2013 6:27 pm

There is no place to put the priority value unless there is a tag. This is why tag ID 0 is allowed -- for layer-2 priority communications of packets belonging to no Vlan. In my experience there are many types of networking devices which get this wrong and will not allow a tag with a vlan ID of zero. I also find a similar problem with equipment not allowing a tag value of 4095 which is the throw-away vlan.

Because of this common implementation problem of not allowing a tag value of zero, I always use vlan tagged packets with ID>0 on all networks. That works better than trying to get all the vendors to fix their implementations.

Who is online

Users browsing this forum: Bing [Bot], felted67, strods, Znevna and 114 guests