Community discussions

MikroTik App
 
dannyboy
Member Candidate
Member Candidate
Topic Author
Posts: 195
Joined: Fri Sep 16, 2005 4:21 am
Location: Nicaragua/USA
Contact:

Redierect hotspot expired users to an information page

Mon Oct 07, 2013 6:42 am

Hello,

I want to be able to redirect hotspot users to an information page when their account is expired. I have read about pppoe and having to change users to a expired profile. The issue with me its that i am using hotspot. I dont want to have to keep track of who is expired and who is not. I want it to do it automatically when they are rejected by the hotspot.

So if I have a user that his account has expired, I want that user to be redirected to an information page where there will be a list of distributors where they can go buy a recharge card. All I need is the code so I can paste on my terminal and edit what I need to edit.

Does anyone have this workign?


Thansk

Dannyboy
 
User avatar
rickfrey
Trainer
Trainer
Posts: 610
Joined: Sun Feb 14, 2010 11:41 pm
Location: Van, Texas
Contact:

Re: Redierect hotspot expired users to an information page

Mon Feb 17, 2014 7:17 am

Many of the RADIUS/ Billing solutions have this ability. How are you authenticating your users?
Launch your company forward with professional training!
http://rickfreyconsulting.com/product-c ... raining-2/
 
dannyboy
Member Candidate
Member Candidate
Topic Author
Posts: 195
Joined: Fri Sep 16, 2005 4:21 am
Location: Nicaragua/USA
Contact:

Re: Redierect hotspot expired users to an information page

Mon Mar 24, 2014 1:49 am

Thank you I got it working!!! ;)
 
User avatar
rickfrey
Trainer
Trainer
Posts: 610
Joined: Sun Feb 14, 2010 11:41 pm
Location: Van, Texas
Contact:

Re: Redierect hotspot expired users to an information page

Mon Mar 24, 2014 4:18 pm

That's great news! Glad to hear it :D
Launch your company forward with professional training!
http://rickfreyconsulting.com/product-c ... raining-2/
 
obadaabdullah
Frequent Visitor
Frequent Visitor
Posts: 71
Joined: Wed Jan 08, 2014 7:41 pm

Re: Redierect hotspot expired users to an information page

Wed Mar 26, 2014 1:07 am

Thank you I got it working!!! ;)
do you use hotspot?
how you got it work???
 
User avatar
moazdabsheh
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Mon Mar 24, 2014 3:10 am
Location: Palestine

Re: Redierect hotspot expired users to an information page

Wed Mar 26, 2014 3:09 pm

Thank you I got it working!!! ;)
aren't you suppose to share your solution with the rest of the forum members so everyone would benefit ?!
 
dannyboy
Member Candidate
Member Candidate
Topic Author
Posts: 195
Joined: Fri Sep 16, 2005 4:21 am
Location: Nicaragua/USA
Contact:

Re: Redierect hotspot expired users to an information page

Wed Mar 26, 2014 3:47 pm

Yes Sorry I thought I did but I guess it was on another forum. Here is what I did:

Redirect to Nopay Site
/ip firewall Nat
add chain=dstnat action=redirect to-ports=8081 protocol=tcp src-address=172.16.50.1-172.16.50.254 dst-port=80 comment=”Redirect to Proxy” disable=no
/ip proxy
Set port=8080,8081
/ip proxy Access
add action=allow disabled=no dst-address= 64.118.86.41
add action=deny disabled=no redirect-to="http://navigowifi.com/payment-reminder.html"


You have to create a profile with that ip pool on pppoe server...

Hope this helped!!
 
User avatar
moazdabsheh
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Mon Mar 24, 2014 3:10 am
Location: Palestine

Re: Redierect hotspot expired users to an information page

Fri Apr 11, 2014 12:09 am

it works well but i noticed something like a bug.
https connection aren't blocked or redirected, such as facebook and google.

anyone who have faced this issue or have a solution ?
 
User avatar
aacable
Member
Member
Posts: 434
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: Redierect hotspot expired users to an information page

Thu Apr 24, 2014 2:34 pm

it works well but i noticed something like a bug.
https connection aren't blocked or redirected, such as facebook and google.
anyone who have faced this issue or have a solution ?
You can simply create a Filter Rule to block the https port 443 for the expired users ip pool.
Last edited by aacable on Fri Apr 25, 2014 6:54 am, edited 1 time in total.
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
User avatar
moazdabsheh
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Mon Mar 24, 2014 3:10 am
Location: Palestine

Re: Redierect hotspot expired users to an information page

Thu Apr 24, 2014 5:40 pm

it works well but i noticed something like a bug.
https connection aren't blocked or redirected, such as facebook and google.
anyone who have faced this issue or have a solution ?
You can simply create a Filter Rule to block the https port 443 for the expired users ip pool to ensure misuse.
enlighten me.

P.S: i'm a big fan of your blog, helped me alot.

Who is online

Users browsing this forum: Baidu [Spider], nichky, shobujkumer4 and 19 guests