Community discussions

 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Known issues and bugs - a list

Tue Nov 12, 2013 4:49 pm

Hey guys,

Since there is currently no official known issues list / bug tracker, lets start one here on the forums.

First, a few disclaimers:
1) This is not an official list, and is not in any way affiliated with MikroTik
2) Only bugs that are still present in current version will be kept here.
3) This is a user forum, and MikroTik is not required to view/acknowledge anything that is written in here.
4) If you report a bug here, please also report it to support@mikrotik.com
5) This is not a "doesnt work for me" list, but a list of reproducable bugs.

How to get a bug added to the list:
See this post for instructions and a template:
http://forum.mikrotik.com/viewtopic.php ... 16#p395374


Here is the current list:
1) MTU error in a PPPoE session on a bonding interface
- http://forum.mikrotik.com/viewtopic.php ... 75#p395375
2) SMS receiving stops working and cant be re-enabled
- http://forum.mikrotik.com/viewtopic.php ... 77#p395377
3) Unable to initialize a system variable via SMS
- http://forum.mikrotik.com/viewtopic.php ... 50#p406340
4) Router looks in the main routing table and not in a VRF for ICMP TTL exceeded (type 11)
- http://forum.mikrotik.com/viewtopic.php ... 00#p414018
5) Queue type default-small not exported with export compact
- http://forum.mikrotik.com/viewtopic.php ... 49#p417649
6) "RouterOS Default Configuration" windows shows when it should not
- http://forum.mikrotik.com/viewtopic.php ... 56#p422756
7) Can't list or delete files with overly long filenames
- http://forum.mikrotik.com/viewtopic.php ... 73#p424572
8) Winbox doesn't unlock files after uploading a whole folder
- http://forum.mikrotik.com/viewtopic.php ... 58#p426189


This list is current for v6.17 release.

Hopefully, more people can contribute.
Last edited by tomaskir on Fri Jul 18, 2014 6:52 pm, edited 60 times in total.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Tue Nov 12, 2013 4:50 pm

How to get a bug added to the list:
1) Post in a separate post
2) Post the exact symptoms, and an exact steps required to reproduce and test the bug
3) Make sure you are testing with the newest version
4) Please post the ticket number from Mikrotik Support under which the bug is submitted.
5) If support has acknowledged the bug, you can update your post with details / info if it will be fixed.

Here is a template you can use to structure you bug report posts:

----- ----- -----
Issue:
[Insert a short name/description for the issue here]

Description:
[Insert a more detailed description here]

Versions affected:
[If more versions than the current version are affected, include them here]

How to reproduce:
[Provide step-by-step instructions on how to reliably reproduce the issue]

Notes:
[Provide any notes or additions you would like]

Support TicketID:
[Ticket ID from support@mikrotik.com]
----- ----- -----
Last edited by tomaskir on Tue Nov 12, 2013 5:33 pm, edited 1 time in total.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Tue Nov 12, 2013 4:51 pm

Issue:
MTU error in a PPPoE session on a bonding interface

Description:
It is impossible to run full 1500 byte frames inside of a PPPoE session if the PPPoE session built on top of a bonding interface.
If you send a 1500 MTU frame over the PPPoE session, it is dropped, and this therefore creates MTU issues in this scenario.

Versions affected:
6.x, not tested on 5.x

How to reproduce:
Lets consider the following topology:
3 RouterBoards: AC, swch and client:
L2 connections:
   AC           swch       client
 ehter4 ------ ether4
 ehter5 ------ ether5
               ether3------ether5
AC:

ros code

/interface bridge
add name="br - pppoe"
/interface ethernet
set [ find default-name=ether4 ] name="ether4 - to swch"
set [ find default-name=ether5 ] name="ether5 - to swch"
/interface bonding
add lacp-rate=1sec mode=802.3ad name="lacp1 - ether4, ether5" slaves="ether4 - to swch,ether5 - to swch"
/ip pool
add name=PPPoE ranges=10.4.0.0/24
/ppp profile
add local-address=1.1.1.1 name=pppoe remote-address=PPPoE
/interface bridge port
add bridge="br - pppoe" horizon=1 interface=ether3
add bridge="br - pppoe" interface="lacp1 - ether4, ether5"
/interface pppoe-server server
add default-profile=pppoe disabled=no interface="br - pppoe" max-mru=1500 max-mtu=1500
/ppp secret
add name=123 password=123 profile=pppoe
/system identity
set name=AC
swch:

ros code

/interface bridge
add name="br - switch"
/interface ethernet
set [ find default-name=ether3 ] name="ether3 - to client"
set [ find default-name=ether4 ] name="ether4 - to AC"
set [ find default-name=ether5 ] name="ether5 - to AC"
/interface bonding
add lacp-rate=1sec mode=802.3ad name="lacp1 - ether4, ether5" slaves="ether4 - to AC,ether5 - to AC"
/interface bridge port
add bridge="br - switch" interface="ether3 - to client"
add bridge="br - switch" interface="lacp1 - ether4, ether5"
/system identity
set name=swch
client:

ros code

/interface pppoe-client
add add-default-route=yes disabled=no interface=ether5 max-mru=1500 max-mtu=1500 name=pppoe-out1 password=123 user=123
/system identity
set name=client
Now lets ping the AC inside of the pppoe session from the client:
Image

As you can see, we cant run full 1500 byte frames inside of the PPPoE session, even tho everything is configured properly.

Notes:
This problem occurs because a binding interface does not report its L2MTU, therefor RouterOS assumes that L2MTU = MTU for the bonding interface, which causes a problem, since the PPPoE session adds 8 bytes as the PPPoE header.

Support TicketID:
Ticket#2013080766000343
Last edited by tomaskir on Thu Apr 24, 2014 2:29 pm, edited 5 times in total.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Tue Nov 12, 2013 4:59 pm

Issue:
SMS receiving stops working and cant be re-enabled

Description:
After 30 minutes, SMS receiving stops working by itself.
It is impossible to re-enable it unless you reboot the router.

Versions affected:
6.11 -> 6.4, not tested rest

How to reproduce:

ros code

/tool sms
set keep-max-sms=20 port=usb1 receive-enabled=yes secret=password
Wait more then 30 minutes and send a SMS to the device.
Log will show:

ros code

15:23:16 gsm,error unable to load unread sms: timeout
Trying to re-enable sms receiving by receive-enabled=yes you get a timeout error"

ros code

/tool sms set receive-enabled=yes
action timed out - try again, if error continues contact MikroTik support and send a supout file (13)
Notes:
Tested with Huawei e220 and e1752
More info also in http://forum.mikrotik.com/viewtopic.php?f=2&t=78593

Support TicketID:
Ticket#2014031466000686
Last edited by tomaskir on Tue Mar 25, 2014 5:23 pm, edited 4 times in total.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Tue Nov 12, 2013 5:10 pm

Issue:
"/system leds" is not exported correctly

Versions affected:
6.6 and 6.5, not tested rest

How to reproduce:

Default config:

ros code

/system leds> exp
# jan/02/1970 00:01:07 by RouterOS 6.6
# software id = 7IXG-ZI8H
#
/system leds
set 0 interface=wlan1
set 1 interface=ether1

ros code

/system leds> exp ver
# jan/02/1970 00:01:08 by RouterOS 6.6
# software id = 7IXG-ZI8H
#
/system leds
set 0 disabled=no interface=wlan1 leds=led1,led2,led3,led4,led5 type=wireless-signal-strength
set 1 disabled=no interface=ether1 leds=user-led type=interface-activity
Apply a little change:

ros code

/system leds
:foreach i in=[find] do= { set $i led="" }
Wrong export output:

ros code

/system leds> exp
# jan/02/1970 00:03:11 by RouterOS 6.6
# software id = 7IXG-ZI8H
#
/system leds
set 0 interface=wlan1
set 1 interface=ether1

ros code

/system leds> exp ver
# jan/02/1970 00:03:24 by RouterOS 6.6
# software id = 7IXG-ZI8H
#
/system leds
set 0 disabled=no interface=wlan1 leds="" type=wireless-signal-strength
set 1 disabled=no interface=ether1 leds="" type=interface-activity

Notes:
As you can see leds=““ is not present in the compact export output.

Support TicketID:
Ticket#2013110566000681
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2279
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Known issues and bugs - a list

Tue Nov 12, 2013 6:11 pm

Hey guys,
Since there is currently no official known issues list / bug tracker, lets start one here on the forums.
Thanks for this list. I hope that will not soon deleted :)
LAN, FTTx, Wireless. ISP operator
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Tue Nov 12, 2013 6:15 pm

Thanks for this list. I hope that will not soon deleted :)
I will be adding more.

If MikroTik chooses to delete this topic, its their choice.
I would be unhappy, but its their forum :)
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
skot
Long time Member
Long time Member
Posts: 586
Joined: Wed Nov 30, 2011 3:05 am

Re: Known issues and bugs - a list

Sat Nov 16, 2013 9:02 am

There's another bug list here: http://bugs.mikrotik-routeros.com/view_all_bug_page.php. I don't know how active it is though...
I don't need any karma... I have Ιησους Χριστος!
 
mistry7
Forum Guru
Forum Guru
Posts: 1245
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: Known issues and bugs - a list

Sun Nov 17, 2013 1:58 am

I ca. Confirm the MTU Issue over L2TP and EOIP
http://forum.mikrotik.com/viewtopic.php?f=2&t=78880

Mistry7
 
User avatar
payday
Member Candidate
Member Candidate
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: Known issues and bugs - a list

Sun Nov 17, 2013 2:51 am

There's another bug list here: http://bugs.mikrotik-routeros.com/view_all_bug_page.php. I don't know how active it is though...
This is great idea but at the moment account cannot be created there. Captcha is not working.
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Sun Nov 17, 2013 4:28 pm

There's another bug list here: http://bugs.mikrotik-routeros.com/view_all_bug_page.php. I don't know how active it is though...
This is great idea but at the moment account cannot be created there. Captcha is not working.
No offense to the maintaners of that list, but it seems to be kinda abandoned.
There are issues there that are still about 5.x, and only a handful have confirmed/resolved status.

Also, finding a list in the official forums is much easier imo.
I will be rechecking all of the issues here with each new ROS release.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
mistry7
Forum Guru
Forum Guru
Posts: 1245
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: Known issues and bugs - a list

Tue Nov 19, 2013 10:27 am

Mikrotik Support did you read these thread?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Tue Nov 19, 2013 12:29 pm

Mikrotik Support did you read these thread?
MikroTik support is located at support@mikrotik.com, just like it says on top of this page. It would be much better and efficient, to submit bugs to mikrotik support, not post them on various (and multiple) online webpages.
No answer to your question? How to write posts
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2279
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Known issues and bugs - a list

Tue Nov 19, 2013 7:01 pm

As tomaskir wrote. All bugs on this site have their own Support TicketID
This means that bugs were reported ......
LAN, FTTx, Wireless. ISP operator
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Tue Nov 19, 2013 7:19 pm

Can we please not argue in here? It seems the topic is headed in that direction, and that is not what I want. :)
We are all here because we like MikroTik, use it, and care about it.

The point of this topic is not to point out flaws and bugs, but to put together a list so people know about existing verified issues/problems, and dont bash their heads agains walls. Every software has bugs and flaws.
I am hoping more people can contribute, and submit issues here in a nicely formatted, reproducable manner, so we all know if something doesnt work and is here in this topic, its a reproducable, support-reported issue.
Mikrotik Support did you read these thread?
Please read disclaimer 3.
MikroTik support is located at support@mikrotik.com, just like it says on top of this page. It would be much better and efficient, to submit bugs to mikrotik support, not post them on various (and multiple) online webpages.
All of the bugs/issues which I personally listed in this topic are reported to support.
One of the points I was hoping to accomplist with this topic is that people submit their bugs to support more and see in what format they could do it to be more helpful.
As tomaskir wrote. All bugs on this site have their own Support TicketID
This means that bugs were reported ......
Even if they are reported, bugs still take a while to fix, MikroTik doesnt have 10 developers they can just throw right away at any issue that arises, we have to understand that. Im not saying there arent issues, or that there arent issues that should have been fixed a long time ago, there certainly are.
And while it is frustrating, being passive-aggressive to a MikroTik staff on forums is not going to help anything :)
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Known issues and bugs - a list

Tue Nov 19, 2013 7:41 pm

We need a bugzilla web interface to view and edit.
 
User avatar
skot
Long time Member
Long time Member
Posts: 586
Joined: Wed Nov 30, 2011 3:05 am

Re: Known issues and bugs - a list

Tue Nov 19, 2013 7:51 pm

I like your idea behind this post and also agree with pcunite that we need a good way to track and organize the bugs. A forum post gets bloated and tedious quickly imo.

We need something 1) easy to use and 2) easy to find, especially for people new to the forum.

Even something as simple a having a new forum category called Bugs would be helpful. And since you can report a bug directly to MikroTik support when submitting a post, that functionality is already built in.
I don't need any karma... I have Ιησους Χριστος!
 
mistry7
Forum Guru
Forum Guru
Posts: 1245
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: Known issues and bugs - a list

Tue Nov 19, 2013 11:57 pm

Bugzilla or Other Bug reporting System is good idear
Better then Mail support@mikrotik.com it is like Playing lotto
To get an answer! When i get One After 2-4 weeks to Tell Support,
I send answer but Never got a Feed back, thats Bad!

And it is Not efficient for Support to get the Same Bug 20 Times,
And Not controlable for coustomers if this Bug is reported allready!

Mistry7
 
K1w1user
newbie
Posts: 31
Joined: Thu Mar 21, 2013 12:28 am

Re: Known issues and bugs - a list

Wed Nov 20, 2013 3:13 am

New Bug

May specific to the RB2011UiAS-RM.

I haven't seen this previously on the RB2011UAS-RM with ROS 6.1.

Encountered with the "as shipped" ROS 6.1

serial console login goes missing after removing default configuration.

I have 10 being updated and configured, and 50% so far have dropped the serial console.

Power up.
via serial port, (r)emove configuration.
add a config and reboot
no serial port login prompt.

Reset Configuration via LCD doesn't fix it.

Fix:
via Winbox, System Console add serial0.
:)
 
Sander
newbie
Posts: 30
Joined: Sat Aug 18, 2012 5:50 am
Location: Shanghai

Re: Known issues and bugs - a list

Wed Nov 20, 2013 4:55 am

Issue:
Source IP of web proxy can't be configured in WinBox and WebFig. Configure it in terminal is Ok.

Description:
Configure source IP address of web proxy in Web Fig will simply not show. Configure it in WinBox will course inconsistency display of WinBox and Terminal, and it does not become effective. Will be lost after close WinBox.

Versions affected:
6.5, 6.6

How to reproduce:
251.png
Notes:
None

Support TicketID:
Submit this post as a bug report to MikroTik Technical Support
You do not have the required permissions to view the files attached to this post.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 9:23 am

This has been explained before. Why Bugzilla interface will not work.

1. Somebody reports a "bug". Something is not working
2. Everyone thinks this is a bug, and starts to worry, to downgrade, to switch to other hardware
3. Support finds that "bug" was actually caused by typo mistake in firewall rule.
4. Bug is closed as "Invalid" but damage in #2 can't be undone

In support emails, 90% of bugs are not bugs, but mistakes. Imagine what will happen, if they will all be listed publicly as "bugs".
No answer to your question? How to write posts
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 11:58 am

Normis, a question:
Does "Submit this post as a bug report to MikroTik Technical Support" here in the forums work? Is sending a ticket directly to support preferable?
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 12:01 pm

Normis, a question:
Does "Submit this post as a bug report to MikroTik Technical Support" here in the forums work? Is sending a ticket directly to support preferable?
It works, but it is preferred that you include a supout.rif file and full description, because we only receive this one post, not whole thread.
No answer to your question? How to write posts
 
dadaniel
Member Candidate
Member Candidate
Posts: 155
Joined: Fri May 14, 2010 11:51 pm

Re: Known issues and bugs - a list

Wed Nov 20, 2013 12:04 pm

In support emails, 90% of bugs are not bugs, but mistakes.
Your e-mail-support is very good, but getting an answer takes way to long. I do not have the time to wait 1 week for each reply of the same case number. Sorry...
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 12:08 pm

Issue:
Source IP of web proxy can't be configured in WinBox and WebFig. Configure it in terminal is Ok.
Tested on a few devices here on my end as well, confirmed. Added to the list, thanks!
New Bug
May specific to the RB2011UiAS-RM.
I haven't seen this previously on the RB2011UAS-RM with ROS 6.1.
Please remember to use the format outlined in the 2nd post if you want a bug added. Also, please remember to use newest ROS, which is 6.6.
Also, please remember, the bugs/issues in here have to be reliably reproducable.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Known issues and bugs - a list

Wed Nov 20, 2013 3:13 pm

This has been explained before. Why Bugzilla interface will not work.

... SKIP ...

In support emails, 90% of bugs are not bugs, but mistakes. Imagine what will happen, if they will all be listed publicly as "bugs".
Normis,
I respectfully disagree with the conclusion of what Bugzilla will do for MikroTik. If you're truly getting 90% configuration mistakes then you have just identified a big problem: communication.

Us techies are here to help your brand for free and I can tell you that they are asking for the simplest of things. I wish there was a place I could send them, a link for the same questions over and over. Bugzilla, at least for me, would show them proof there is not bug.

The perception I'm getting from others about your brand is that, it is buggy. Bugzilla is not your problem. Small thinking will be the death of you guys. Think big!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 3:21 pm

RouterOS is very complex, there are huge configurations that can be made. Sometimes finding this configuration mistake takes days. There will be no "one place" to send them to, as every case is unique. RouterOS is not something like "Firefox", where all solutions are "click here, not here". It is very rare that two people will have same problem and same solution.
No answer to your question? How to write posts
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Known issues and bugs - a list

Wed Nov 20, 2013 3:41 pm

Normis,
You know more about MikroTik than I do, so I won't argue your points. However, understand that I'm personally responsible for people purchasing seven different MikroTik products in the last months and I did not make a dime on that.

Give us something to help your brand. Make videos of the most common questions. If it was not for Greg Sowell's outdated videos on YouTube I would be lost. The MUM videos are way too hard to hear or understand. This is not an insult but those people are not gifted teachers, they are techies.

MikroTik can do better. We are on your side. Open up some more ... nothing bad will come of that.
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 4:11 pm

On the issue of bugzilla, or a similar public web-interface, I am also against it. It would get bloated to death with millions of posts that are not bugs, but problems in configs, people not understanding how something works, etc. Also, you have to realize that implementing something as bugzilla into their system, MikroTik is opening more potential security holes into their systems, has another system for maintanance, etc. You have to look at it from MikroTiks point of view as well, it would be a lot of work, testing, verification and QA needed to implement it, for potentionally small benefits.

I do agree that there really should be an official bug/issue tracker, but that has been discussed on the forums forever... so lets not go into that. If/when MikroTik chooses to make one, it will happen, untill then we can only hope.

I would really like if wiki was more often updated tho. Also, in some sections, its bloated with not-needed material, while in others, it lacks details. But again, MikroTik is what it is in that regard, its the same as with ROS change-logs, people have been asking for more detailed change-logs forever now.

To pcunite:
Send those people to wiki. I often find that people just refuse to read, when most of MikroTik is actually fairly well described and documented on the wiki.

Since official "manual" content on the wiki can not be edited by users, maybe a system where edits can be offered, considered and then approved by official MikroTik staff would help. You know, wiki's are kinda made for that.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 4:15 pm

Wiki is open for registration by request. I will gladly offer you editing rights to our Wiki. Public registration was closed because of spam, and people promoting their services. If you only wish to correct the occasional mistake in our content, you are welcome to contact us for an account
No answer to your question? How to write posts
 
voxframe
Member Candidate
Member Candidate
Posts: 126
Joined: Thu Dec 16, 2010 2:51 pm

Re: Known issues and bugs - a list

Wed Nov 20, 2013 4:19 pm

Normis,

I agree that an open public bug system is a bad idea.

HOWEVER, what I wish Mikrotik would do is have some form of public list of EXACTLY what known bugs are currently in the firmware, what kind of fixes are being applied, and what is the ETA of each one.

There needs to be a single, up-to-date reference for people to check so they may become aware of what are the known issues.

If someone sends you a support file, and you find a bug, POST IT!
If you're working on a bug that you found, and it's scheduled to be in update XX, POST IT!

There needs to be more clear communications from the development team regarding issues/bugs/problems/fixes/ETAs/etc.

Currently they are a mess of spread out topics on a forum, they are nearly impossible to search without wasting a lot of time.

The forum is NOT a good method for dealing with this, unless it is a locked topic that is sticky to the top of each page (And it actually gets updated on a regular basis! Every morning for example)
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 4:23 pm

I agree with Voxframe. We currently post very widespread issues on the Download page in a "Note", but this is not always the case. We will try to improve in this area. We would like to avoid scaring people from upgrading, if the known bug is specific only to some configurations, it's one of the reasons we haven't made such list yet.
No answer to your question? How to write posts
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Wed Nov 20, 2013 4:28 pm

Wiki is open for registration by request. I will gladly offer you editing rights to our Wiki. Public registration was closed because of spam, and people promoting their services. If you only wish to correct the occasional mistake in our content, you are welcome to contact us for an account
Are you talking about actually editing the topics uder Manual? http://wiki.mikrotik.com/wiki/Manual:TOC

I have a wiki account from the days of old, and I have written a few wiki articles. However, currently on the wiki there is only editing, there is no way to offer and edit that can be discussed and then approved by you (MikroTik).

I would be happy to offer some edits and changes from my perspective. I would happily spend time going through the wiki, looking for for things that can be clarified, potential errors, etc.
But I do not want to touch the official documentation without my changes first being reviewed and approved by MikroTik staff, and afaik, that functionality is not on the wiki.

EDIT: Also thank you for joining us and actually discussing these things with us Normis.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: Known issues and bugs - a list

Wed Nov 20, 2013 4:50 pm

I'm really scared to edit the wiki because I need my writings to be verified. For example my VoIP QoS article has not been verified by experts. It's almost like we need a separate area for document writers and testers to share their experiences and get feedback from experts at MikroTik. Keep out the newbs in this area. MikroTik is not going to scare me personally away from their products because I'm made aware of bugs. I already know about your bugs! :-)

Here is what MikroTik needs to work hard on and get us all on board with.
  • 1. Why are we scared to update? Fear of the unknown is one reason.
    2. Who is the public product evangelist for MikroTik that makes me look good when I refer people to you?
    3. Who is responsible for making beautifully done videos (and wiki articles) that answer the top 20 questions?
I’m not an Apple fan boy (I use Android) but they control the software and the hardware and that makes for a great experience. MikroTik needs to control the platform for the education and support of their users. By platform I mean a great website where I can help others, where MikroTik helps me. Why is VoIP optimization sold by a third party individual for $200 when MikroTik knows how to do this better than anyone? I can make money and so can MikroTik if we open up the communication better.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2279
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Known issues and bugs - a list

Wed Nov 20, 2013 5:14 pm

This has been explained before. Why Bugzilla interface will not work.

1. Somebody reports a "bug". Something is not working
2. Everyone thinks this is a bug, and starts to worry, to downgrade, to switch to other hardware
3. Support finds that "bug" was actually caused by typo mistake in firewall rule.
4. Bug is closed as "Invalid" but damage in #2 can't be undone

In support emails, 90% of bugs are not bugs, but mistakes. Imagine what will happen, if they will all be listed publicly as "bugs".
You have true. If bugzila not suitable, suggest a way to inform the (forum) Mikrotik users.
For example: Official topic on forum -> you want to edit it as needed.

For example, in the current version 6.6 is a bug when using the VLAN on Bridge. But how does it know? Read Topic 6.6 and browse and search all sides who reported what ...
LAN, FTTx, Wireless. ISP operator
 
alexspils
Member Candidate
Member Candidate
Posts: 174
Joined: Thu Jun 05, 2008 8:57 pm

Re: Known issues and bugs - a list

Wed Nov 20, 2013 5:59 pm

Issue:
DHCP Not work with intel i350-t4
Versions affected:
6.6->6.2,5.26 ok
How to reproduce:
Enable dhcp server on any of 4 eth ports of card,add lease for test pc or config dynamic pool and try to receive ip.
 
Sander
newbie
Posts: 30
Joined: Sat Aug 18, 2012 5:50 am
Location: Shanghai

Re: Known issues and bugs - a list

Thu Nov 21, 2013 6:30 am

Issue:
DNS cache does not update for static DNS name change

Description:
DNS cache will add new record instead of update when you change a static DNS name.

Versions affected:
6.6

How to reproduce:
Add a static DNS record with name "test.local" and address "192.168.8.1", then change name to "test1.local". You will see a new record "test1.local" added to cache, and "test.local" is still there.
252.png
Notes:
I can't find any way to delete "test.local" in DNS cache, except router reboot.

Support TicketID:
None, not report to MikroTik Technical Support
You do not have the required permissions to view the files attached to this post.
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Fri Nov 22, 2013 12:36 pm

Issue:
DNS cache does not update for static DNS name change
Verified and added to the list.

PLEASE submit this to support@mikrotik.com and update your post with a support ticket ID.
Just copy your post from here to the email, it should be enough.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Fri Nov 22, 2013 12:54 pm

Issue:
DNS cache does not update for static DNS name change
Verified and added to the list.

PLEASE submit this to support@mikrotik.com and update your post with a support ticket ID.
Just copy your post from here to the email, it should be enough.
I checked this several times, and can't get it to repeat. Please submit to support with detailed steps how to repeat.
No answer to your question? How to write posts
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Fri Nov 22, 2013 1:03 pm

I checked this several times, and can't get it to repeat. Please submit to support with detailed steps how to repeat.
Here is a ticket with exact steps: Ticket#2013112266000451

Any more info on all the discussion about the wiki? I think that was actually a fairly fruitful and useful debate :)
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
doush
Long time Member
Long time Member
Posts: 615
Joined: Thu Jun 04, 2009 3:11 pm

Re: Known issues and bugs - a list

Fri Nov 22, 2013 2:51 pm

Normis;

Just make a known issues thread for each version. That is very simple.
Let us know what is buggy.
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Mon Nov 25, 2013 11:25 am

Issue:
PPTP/SSTP - could not add bridge port - BCP not working

Description:
BCP for SSTP and PPTP does not work, if a client with a bridge configured attemts to connect, he can not. Errors in logs stay "could not add bridge port"

Versions affected:
6.7, 6.6

How to reproduce:
Connect 2 RBs on ether 5.

Apply config for AC:

ros code

/interface pptp-server
add name=pptp-in1 user=pptp
/interface sstp-server
add name=sstp-in1 user=pptp
/interface bridge
add name=br_ppp
/ppp profile
add bridge=br_ppp local-address=2.2.2.1 name=pptp remote-address=2.2.2.2
/interface bridge port
add bridge=br_ppp interface=ether3
/interface pptp-server server
set default-profile=pptp enabled=yes keepalive-timeout=5
/interface sstp-server server
set default-profile=pptp enabled=yes keepalive-timeout=5 max-mru=1450 max-mtu=1450
/ip address
add address=1.1.1.1/24 interface=ether5 network=1.1.1.0
/ppp secret
add name=pptp password=pptp profile=pptp
/system identity
set name=SSTP_AC
Apply configs for client:

ros code

/interface bridge
add name=br_ppp
/ppp profile
add bridge=br_ppp name=pptp
/interface sstp-client
add connect-to=1.1.1.1 keepalive-timeout=5 name=sstp-out1 password=pptp profile=pptp user=pptp verify-server-address-from-certificate=no
/interface pptp-client
add connect-to=1.1.1.1 keepalive-timeout=5 name=pptp-out1 password=pptp profile=pptp user=pptp
/interface bridge port
add bridge=br_ppp interface=ether3
/ip address
add address=1.1.1.2/24 interface=ether5 network=1.1.1.0
/system identity
set name=SSTP_Client
PPTP and SSTP can not connect. Errors in log regarding "could not add bridge port"

Notes:
If you disable the static binding on the AC, sometimes the client connects, and sometimes the same error occurs in the logs on the client.

Support TicketID:
Ticket#2013112566000268
Last edited by tomaskir on Mon Dec 02, 2013 3:43 pm, edited 1 time in total.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Mon Dec 02, 2013 12:37 pm

Issue:
L2TP Server bug - replies from wrong IP address

Description:
When a router has multiple IP addresses on an interface, an L2TP server always uses the lowest IP address as the source address of L2TP packets, which makes the L2TP connection impossible to establish.

Versions affected:
6.14-6.0, 5.x

How to reproduce:
Connect 2 RB's on ether5. Apply configs:

L2TP AC:

ros code

/interface l2tp-server server
set enabled=yes
/ip address
add address=10.0.0.1/24 interface=ether5 network=10.0.0.0
add address=1.1.1.1/32 interface=ether5 network=1.1.1.1
/ip firewall mangle
add action=log chain=input port=1701 protocol=udp
add action=log chain=output port=1701 protocol=udp
/ppp secret
add name=123 password=123
/system identity
set name=AC
L2TP client:

ros code

/interface l2tp-client
add connect-to=1.1.1.1 name=l2tp-out1 password=123 user=123
/ip address
add address=10.0.0.2/24 interface=ether5 network=10.0.0.0
/ip route
add distance=1 gateway=10.0.0.1
/system identity
set name=Client
L2TP will not establish. Looking at the logs will show that the L2TP server replies with a wrong IP address:
Image


Notes:
This is really annoying, especially if you have a public IP which the clients use to connect to the L2TP server on a loopback.
The lowest IP address of the incoming interface will still be used, instead of the public IP on the loopback, making the L2TP AC not work.

You can use NAT as a workaround.

ros code

/ip firewall nat
add action=dst-nat chain=dstnat comment="Fix for an L2TP src-address bug" dst-address="Address you want your L2TP client to connect to" \
 dst-port=1701 protocol=udp to-addresses="src-address that L2TP sends wrong packets with"
Support TicketID:
Ticket#2013020866000414
Last edited by tomaskir on Fri Jul 18, 2014 12:49 pm, edited 6 times in total.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Mon Dec 02, 2013 4:02 pm

All issues re-tested on v6.7 release. The list is now current for v6.7
2 out of 7 bugs on the list at the release of v6.7 were fixed.

The following issues from the list have been fixed in 6.7:

1) "/system leds" is not exported correctly
- http://forum.mikrotik.com/viewtopic.php ... 82#p395382
2) DNS cache does not update for static DNS name change
- http://forum.mikrotik.com/viewtopic.php ... 57#p396750
Last edited by tomaskir on Mon Dec 02, 2013 4:56 pm, edited 1 time in total.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
janisk
MikroTik Support
MikroTik Support
Posts: 6283
Joined: Tue Feb 14, 2006 9:46 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Mon Dec 02, 2013 4:45 pm

regarding this: http://forum.mikrotik.com/viewtopic.php ... 77#p395377
check if your 3g usb module is not hanging. In our testing we did not see any issues.
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Mon Dec 02, 2013 4:57 pm

regarding this: http://forum.mikrotik.com/viewtopic.php ... 77#p395377
check if your 3g usb module is not hanging. In our testing we did not see any issues.
It could be specific to only the 2 USB modems I tested, however even if the modems are rebooted with usb-power-reset, the issue continues. (however, after a routerboard reboot, they work)
Also, a few other people in the forum reported problems.
A bit more info can be found here: http://forum.mikrotik.com/viewtopic.php?f=2&t=78593 (and my last post in that topic) or in the support ticket mentioned in the post in this topic.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24077
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: Known issues and bugs - a list

Thu Dec 05, 2013 8:27 am

Known Issue in v6.7

Duplicate address-list entries (same list name and same address or address range) are causing a crash. Avoid making 2 identical entries, or write to support for v6.8rc1 pre-release version with the fix.

Thanks for your support, and keep sending emails to support if you find any problems.
No answer to your question? How to write posts
 
User avatar
vipe
Member Candidate
Member Candidate
Posts: 166
Joined: Thu Sep 14, 2006 10:05 pm

Re: Known issues and bugs - a list

Thu Dec 05, 2013 10:08 am

 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2279
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: Known issues and bugs - a list

Thu Dec 05, 2013 10:48 am

Thanks for info Normis!!
LAN, FTTx, Wireless. ISP operator
 
User avatar
tomaskir
Trainer
Trainer
Topic Author
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: Known issues and bugs - a list

Thu Dec 05, 2013 11:33 am

Thank you for telling us Normis!

Added to the list.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!

Who is online

Users browsing this forum: No registered users and 52 guests