Community discussions

MikroTik App
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Fixing the minimum bandwidth

Sun Jun 15, 2014 6:19 pm

Hi guys, Im going to buy a routeros device from mikrotik.

I just need an answer for one question. Lets say I have 5 Mbps internet and I have 2 user connected to it. Users may play online game so needs lowest latency possible and for this they need at least 2 Mbps bandwidth available. (I cannot trace the tcp-udp ports used per game because not only there are many games to consider but also some ports are dynamic) So came up with this idea.

To conclude, can I do that. I mean users shouldn't go down below 2 Mbps.

bad scenario: Im downloading heavily and my brother plays online game and he is getting high pings.
scenario to accomplish: Im downloading heavily and my brother plays online game and when he is active my bandwidth will be cut in order to give him 2 mbps and he will get low pings.

same scenario has to apply opposite directions too, like me playing games and he downloads etc.

note: as we cannot detect he is playing so we consider that if the user is making a traffic then make his speed wont go below 2 mbps.
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 6:42 pm

There's no question in that entire post...

I assume you're asking if RouterOS can do that? It can. Using simple queues (the "/queue simple" menu).

You create one master queue where you specify your available speed, and then per user, you add a queue that has that master queue as parent. In the per user queues, you can specify the minimum speed using "limit-at", while the maximum speeds are specified using "max-limit".

Strictly speaking though... Using the above setup, RouterOS is smart enough to divide the total speed in two equal parts, with or without "limit-at". The only time you really must use "limit-at" is when you need to give UNequal speed to certain user(s), e.g. if you wanted to make sure the first user always has at least 3 Mbps, and up to 5 Mbps if the second user is not online.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 6:53 pm

Yep this is what I want, you gave the answer already :)

Can you demonstrate it on routeros?
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 7:13 pm

The commands from a terminal:

ros code

/queue simple
add name=total target=192.168.88.0/24 max-limit=5M/5M
add name=user1 target=192.168.88.254/32 max-limit=5M/5M limit-at=2M/2M parent=total
add name=user2 target=192.168.88.253/32 max-limit=5M/5M limit-at=2M/2M parent=total
(Assuming the local subnet is 192.168.88.0/24, which is at least the case for some RouterBOARDs; Adjust accordingly if using a different subnet)
Last edited by boen_robot on Sun Jun 15, 2014 9:14 pm, edited 1 time in total.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 8:18 pm

can we make the total and max limit unlimited?

edit: aldo important, can I refer to interfaces? Not ip addresses. I mean simple queues on eth2-eth3 and wifi interface?
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 8:58 pm

can we make the total and max limit unlimited?
You mean the total's max-limit? No. There's no way for RouterOS to "just know" how much speed your ISP provides to you. The max-limit in the "total" queue tells RouterOS "this is how much speed I have from my ISP; divide it between your children".

You can have the children's max-limit be unlimited... Although I recently made tests in recent RouterOS versions (6.13 was the last one I checked), and there seems to be a new bug, in that a child with "unlimited" gets "unlimited" speed, rather than the parent's max-limit speed... Which in turn means that children will be "fighting" for the speed, rather than divide it.

(I'll write to support when I have time to try it with 6.15, and that fails too)
can I refer to interfaces? Not ip addresses. I mean simple queues on eth2-eth3 and wifi interface?
Yes. In fact, for my queues, I have the "total" queue match the local interface... But I avoided it in the example above, as I couldn't remember the default interface name for the local bridge on RouterBOARD, and the board is not with me now.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 9:11 pm

Yes I will make a bridge for all interfaces I have so for total I will use bridge1. and for user 1 I will use eth2 etc.

It is healthy to do it in winbox right? Because command you gave is kind of incomplete.
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 9:14 pm

It is healthy to do it in winbox right? Because command you gave is kind of incomplete.
If you mean Winbox's "New Terminal"... Yes. It's in fact equivalent with doing it any other command line kind of way.


Doing it with Winbox is similar. You go to the "Queue" menu, the "Simple" tab, click "+" (which stands for "Add"), adjust the settings in accordance with the arguments, etc.


(Side note: Opps... I forgot to name "user2" differently; Fixed...)
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 9:19 pm

I found this.. https://www.youtube.com/watch?v=G8Gug78SXlM

Now, I will do just one queue, limit at 2 max limit 5 with no target address and in advanced interface select the all. Will it work?

edit: in the end, all of the devices (bridge1 (all eths+wifi)) have the minimum of 2 mbps so in online games pings will be minimum.. am I right?
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 9:29 pm

I found this.. https://www.youtube.com/watch?v=G8Gug78SXlM

Now, I will do just one queue, limit at 2 max limit 5 with no target address and in advanced interface select the all. Will it work?
That's how things worked in RouterOS 5.*, yes. In RouterOS v6, the "interface" drop down (and it's equivalent argument) is removed. Instead, the "target" argument can take the interface name.

Also, in the total queue, you don't really need a limit-at, since you're only really using it to specify the "maximum" to then be divided among individual devices.


On that note, I should probably clarify that if you target an interface, you're saying that the TRAFFIC of all devices IN TOTAL is the specified limit. Using an interface as a target is NOT a shortcut for "any INDIVIDUAL device from that interface". In other words, having

ros code

add name=bridge1queue target=bridge1 max-limit=5M/5M
does NOT mean that 192.168.88.254 will get 5M upload and 5M download, and 192.168.88.253 will get another 5M upload and another 5M download, for a total of 10M speed consumption.

No... it means 192.168.88.254 and 192.168.88.253 share a speed of 5M upload and 5M download (so up to 2.5M each when both are present).

(assumes "bridge1" uses 192.168.88.0/24 as a subnet)

So...
edit: in the end, all of the devices (bridge1 (all eths+wifi)) have the minimum of 2 mbps so in online games pings will be minimum.. am I right?
Not exactly, since limit-at (and max-limit for that matter) is pointless if your ISP can't deliver the specified speed. And if your ISP is indeed offering a 2 Mbps guaranteed speed, then yes, with that one queue, 2 Mbps will be the speed that all devices share, so 1 Mbps each, if you have two devices, 512 kbps if you have 4, etc.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 10:25 pm

OK I see now, Im thinking different..

I just need eth2 and eth3 should have at least 2 mbps in all conditions. Whats the ros code for that?
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Sun Jun 15, 2014 11:11 pm

OK I see now, Im thinking different..

I just need eth2 and eth3 should have at least 2 mbps in all conditions. Whats the ros code for that?
If there's only one device connected to eth2, and only one device connected to eth3, then it's the exact same thing as above, but with IPs replaced with interface names, so:

ros code

/queue simple
add name=total target=bridge1 max-limit=5M/5M
add name=user1 target=eth2 max-limit=5M/5M limit-at=2M/2M parent=total
add name=user2 target=eth3 max-limit=5M/5M limit-at=2M/2M parent=total
(assuming "bridge1" includes eth2, eth3, and perhaps other interfaces)

If there are multiple devices, all connected to, let's say eth2, they are going to share the 2 Mbps allocated for eth2.


It's just that you need ALL of those queues... There's no "quick & dirty" way to specify "everyone should have at least 2 Mbps". You must explicitly tell the router "This IP/interface has at least 2 Mbps, and this IP/interface has at least 2 Mbps [and this...[and this...]], and the remaining speed - the total of which is 5 Mbps, should be shared equally between this IP/interface, this IP/interface [and this...[and this...]]".
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Jun 16, 2014 12:39 am

Alright man thanks a lot! :)
I Walk Alone
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Wed Jun 18, 2014 8:01 pm

I found this...
/queue simple
#name=”Day” target-addresses=192.168.1.5/24 dst-address=0.0.0.0/0
interface=<ether-3> parent=none direction=both priority=1
queue=default-small/default-small limit-at=2M/2M
total-queue=default-small
/queue simple
add name=us1 target=eth1 limit-at=2M/2M
Can I do this for one user? That this user won't go below 2 Mbps?
I Walk Alone
 
n21roadie
Forum Guru
Forum Guru
Posts: 1896
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Fixing the minimum bandwidth

Wed Jun 18, 2014 8:20 pm

......................... Users may play online game so needs lowest latency possible and for this they need at least 2 Mbps bandwidth available....................................
Can I ask how did you calculate minimum bandwidth for lowest latency ?????????
N21roadie,
Network 100% MT for Now?
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Wed Jun 18, 2014 9:32 pm

......................... Users may play online game so needs lowest latency possible and for this they need at least 2 Mbps bandwidth available....................................
Can I ask how did you calculate minimum bandwidth for lowest latency ?????????
It is a fact that online games need bandwidth for smooth game play. If I start downloading something that will consume all the bandwidth and online game will lag. If I reserve 1-2 Mbps at least for a user, game wont lag even if I start downloading something.

This doesnt need any calculation, just see the requirements of online games they need at least 1 Mbps connection :) 2 Mbps should be enough for all games.

edit: BF4 can take up 1.5 Mbps sometimes with the latest patch.
I Walk Alone
 
n21roadie
Forum Guru
Forum Guru
Posts: 1896
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Fixing the minimum bandwidth

Thu Jun 19, 2014 1:58 am


It is a fact that online games need bandwidth for smooth game play. If I start downloading something that will consume all the bandwidth and online game will lag. If I reserve 1-2 Mbps at least for a user, game wont lag even if I start downloading something.

This doesnt need any calculation, just see the requirements of online games they need at least 1 Mbps connection :) 2 Mbps should be enough for all games.

edit: BF4 can take up 1.5 Mbps sometimes with the latest patch.
Depending on the game being used some only require any speed above dial up and others require 1+Mbps, but this has nothing to do with latency, I would first test the ISP latency and incoming bandwidth during peak usage hours, from the results calculate.
N21roadie,
Network 100% MT for Now?
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Thu Jun 19, 2014 1:00 pm


It is a fact that online games need bandwidth for smooth game play. If I start downloading something that will consume all the bandwidth and online game will lag. If I reserve 1-2 Mbps at least for a user, game wont lag even if I start downloading something.

This doesnt need any calculation, just see the requirements of online games they need at least 1 Mbps connection :) 2 Mbps should be enough for all games.

edit: BF4 can take up 1.5 Mbps sometimes with the latest patch.
Depending on the game being used some only require any speed above dial up and others require 1+Mbps, but this has nothing to do with latency, I would first test the ISP latency and incoming bandwidth during peak usage hours, from the results calculate.
pings and bandwidth is 7/24 stable now :) I have no problem on the ISP side.
I have extra lcd to monitor every thing inside the computer, I have seen 250 Kbps minimum on online games max 1.4 Mbps (for a second in bf4), so reserving 2 Mbps would be more efficient for pings.

Why you said this has nothing to do with pings? Yes it has. :)
I Walk Alone
 
n21roadie
Forum Guru
Forum Guru
Posts: 1896
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Fixing the minimum bandwidth

Thu Jun 19, 2014 4:29 pm


pings and bandwidth is 7/24 stable now :) I have no problem on the ISP side.
I have extra lcd to monitor every thing inside the computer, I have seen 250 Kbps minimum on online games max 1.4 Mbps (for a second in bf4), so reserving 2 Mbps would be more efficient for pings.

Why you said this has nothing to do with pings? Yes it has. :)
The term latency refers to any of several kinds of delays typically incurred in processing of network data, for example you could have incoming bandwidth of 10Mbps and downloading a file at 128Kps but latency of several hundreds ms - why?
The router processor was locked up and running at 100% (a reboot will usually solve), so bandwidth only solution will not always give the lowest latency as other factors (MTU matching, router CPU load,..etc.) effect latency?
N21roadie,
Network 100% MT for Now?
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Thu Jun 19, 2014 4:33 pm


pings and bandwidth is 7/24 stable now :) I have no problem on the ISP side.
I have extra lcd to monitor every thing inside the computer, I have seen 250 Kbps minimum on online games max 1.4 Mbps (for a second in bf4), so reserving 2 Mbps would be more efficient for pings.

Why you said this has nothing to do with pings? Yes it has. :)
The term latency refers to any of several kinds of delays typically incurred in processing of network data, for example you could have incoming bandwidth of 10Mbps and downloading a file at 128Kps but latency of several hundreds ms - why?
The router processor was locked up and running at 100% (a reboot will usually solve), so bandwidth only solution will not always give the lowest latency as other factors (MTU matching, router CPU load,..etc.) effect latency?
I see your point.. but these are some extreme cases which I have never seen in my life.. so in my case that ups the latency is 100% of the time bandwidth consuming. that my goal is to limit-at it 2 mbps for my brother and myself and problem will be gone hopefully.

edit: OK, for the moment, put all those things at another side, in your opinion what would be the best way to accomplish my goal?
I Walk Alone
 
n21roadie
Forum Guru
Forum Guru
Posts: 1896
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Fixing the minimum bandwidth

Thu Jun 19, 2014 5:58 pm


I see your point.. but these are some extreme cases which I have never seen in my life.. so in my case that ups the latency is 100% of the time bandwidth consuming. that my goal is to limit-at it 2 mbps for my brother and myself and problem will be gone hopefully.

edit: OK, for the moment, put all those things at another side, in your opinion what would be the best way to accomplish my goal?
I would establish where the problem is and if there is a problem with just one connection from the ISP, monitor latency as download bandwidth is increased, no point in wasting time if the issue is due to ISP congestion.
If ISP OK then match MTU (ping ip size=1480 do-not-fragment) ( i assume its a pppoe connection to isp you have) try other sizes until fragmentation stops, this is your MTU for the router, remove any packages not required (hotspot..etc) on the router from /system package, check router CPU load at max download, then set bandwidth for each connection - is your connection used from router, ether or wireless or both.
N21roadie,
Network 100% MT for Now?
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Thu Jun 19, 2014 7:21 pm


I see your point.. but these are some extreme cases which I have never seen in my life.. so in my case that ups the latency is 100% of the time bandwidth consuming. that my goal is to limit-at it 2 mbps for my brother and myself and problem will be gone hopefully.

edit: OK, for the moment, put all those things at another side, in your opinion what would be the best way to accomplish my goal?
I would establish where the problem is and if there is a problem with just one connection from the ISP, monitor latency as download bandwidth is increased, no point in wasting time if the issue is due to ISP congestion.
If ISP OK then match MTU (ping ip size=1480 do-not-fragment) ( i assume its a pppoe connection to isp you have) try other sizes until fragmentation stops, this is your MTU for the router, remove any packages not required (hotspot..etc) on the router from /system package, check router CPU load at max download, then set bandwidth for each connection - is your connection used from router, ether or wireless or both.
I cant touch the MTU its 1500 default coming from the ISP, not pppoe, dhcp wan. Cant check current router cpu because I do not have routerboard. my connection is on LAN from my cisco x1000 router.

As I said earlier, when I use all the bandwidth, naturally pings go up as it should be. When I limit speed in utorrent pings go normal. And btw, this same scenerio happened before when I use ADSL2 as well :)

edit: I just searched for a beautiful router that shapes bandwidth and has all the control over the network and I found it after a long time! RouterBoard! Last week, I've just learnt the basics of RouterOS I studied it. Hopefully, I will buy 951ui.
I Walk Alone
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 2:45 pm

So I have bought the device and configured it really fine.. but simple queue isnt working.. its not showing the traffic.. why is that?
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 4:19 pm

So I have bought the device and configured it really fine.. but simple queue isnt working.. its not showing the traffic.. why is that?
Have you added the "Download" and "Upload" columns in Winbox? Or are you saying that you've added them, but they remain at "0 bps" even when you start downloading something?
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 4:36 pm

So I have bought the device and configured it really fine.. but simple queue isnt working.. its not showing the traffic.. why is that?
Have you added the "Download" and "Upload" columns in Winbox? Or are you saying that you've added them, but they remain at "0 bps" even when you start downloading something?
yes 0 bps all the time.. but I havent add the parent total.

edit: cam someone demonstrate it in winbox? pleaseee? :)
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 5:20 pm

So I have bought the device and configured it really fine.. but simple queue isnt working.. its not showing the traffic.. why is that?
Have you added the "Download" and "Upload" columns in Winbox? Or are you saying that you've added them, but they remain at "0 bps" even when you start downloading something?
yes 0 bps all the time.. but I havent add the parent total.

edit: cam someone demonstrate it in winbox? pleaseee? :)
Shooting a video (or even making a series of screenshots) is harder than clicking "New Terminal" from Winbox, then right clicking inside the window and clicking "Paste" to paste the required text (above)... You're not asking for an "Extra mile" help... you're asking for "Several extra miles help".
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 6:33 pm

I didnt use the terminal.

turned out that it does not like target for interface names :D lol but when I click it only interface names are there to select :) anyways, I put the ip address on it and its fine :)

note: didnt use total for parent, no parent at all..
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 6:39 pm

Upgrade to v6.*.

Go to "System > Packages", click "Check for Upgrades", and click "Download & Upgrade".
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 6:55 pm

Upgrade to v6.*.

Go to "System > Packages", click "Check for Upgrades", and click "Download & Upgrade".
did that at the very beginning.. 6.15 latest

help, guys I had to include the total and in total I select 192.168.1.0/24 and see the traffic goes but it does not show the wi-fi traffic, yet wi-fi is also in this subnet.. Im lost :)

edit: I can see the traffic in bridge->bridge1 traffic with every devices that are on bridge1 BUT
I cannot see the all traffic in bridge1 in simple queue.

is that a bug?

I cannot control built in wlan in simple queues... .. :(

its a bug.. I needed to make a static ip for devices that connected to the wlan.. target certainly DOES NOT like interface names. only ips.

and yes... finally, I got what I want :) ..
without wimple queues. speedtest on wlan + pc ping test = high pings
with simple queues speedtest on wlan + pc ping test = low pings (just normal pings)
I Walk Alone
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 9:18 pm

a little bit advanced question, can the router change dynamically the totals max download limit based on a time schedule?

edit: noob question: when you paste commands in the terminal, does it run immediately? Or need to press Enter?
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 9:37 pm

a little bit advanced question, can the router change dynamically the totals max download limit based on a time schedule?
Yes. Check the "time" section in Winbox at your parent queue (or at the child, if you only want to adjust a specific host at a particular time, but your ISP's speeds are constant).
edit: noob question: when you paste commands in the terminal, does it run immediately? Or need to press Enter?
They run immediately. Sometimes, when you copy&paste, you may end up copy&paste without the last new line. In that event, the last command (only) won't be executed until you press Enter.


If you want to prevent them from running immediately, you can type "{", hit Enter, and then paste to your delight. The commands will only be executed when you type "}" and hit Enter.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 10:09 pm

first I tried to paste your command on simple queues but it was a mess I mean straight one line code, there were no spaces and new lines.. and I think it did nothing because I checked the simple queue and it was empty.
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 10:16 pm

first I tried to paste your command on simple queues but it was a mess I mean straight one line code, there were no spaces and new lines.. and I think it did nothing because I checked the simple queue and it was empty.
Uhhh... the code box in this forum can sometimes do that...

Perhaps putting it in "code" tags instead of "code2" ones will help... try pasting from these:
/queue simple
add name=total target=192.168.88.0/24 max-limit=5M/5M
add name=user1 target=192.168.88.254/32 max-limit=5M/5M limit-at=2M/2M parent=total
add name=user2 target=192.168.88.253/32 max-limit=5M/5M limit-at=2M/2M parent=total
/queue simple
add name=total target=bridge1 max-limit=5M/5M
add name=user1 target=eth2 max-limit=5M/5M limit-at=2M/2M parent=total
add name=user2 target=eth3 max-limit=5M/5M limit-at=2M/2M parent=total
If even that doesn't help, there's always the nuclear option... adding freakin' ";" on every command, i.e.

ros code

/queue simple;
add name=total target=192.168.88.0/24 max-limit=5M/5M;
add name=user1 target=192.168.88.254/32 max-limit=5M/5M limit-at=2M/2M parent=total;
add name=user2 target=192.168.88.253/32 max-limit=5M/5M limit-at=2M/2M parent=total;

ros code

/queue simple;
add name=total target=bridge1 max-limit=5M/5M;
add name=user1 target=eth2 max-limit=5M/5M limit-at=2M/2M parent=total;
add name=user2 target=eth3 max-limit=5M/5M limit-at=2M/2M parent=total;
When collapsed to a single line, the ";" makes sure to separate the different commands, and RouterOS accepts that as a valid syntax.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Jun 23, 2014 10:40 pm

thanks :) I already done that within the winbox.
I Walk Alone
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Tue Jun 24, 2014 9:04 pm

I added my other devices but they dont get the limit at speed when someone downloads something.. I tried mangles with queue trees as well no luck.. :(
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Tue Jun 24, 2014 9:24 pm

I added my other devices but they dont get the limit at speed when someone downloads something.. I tried mangles with queue trees as well no luck.. :(
You do have the parent queue in there now, right?

Try to change the parent queue to use IPs as well (since perhaps interface matching is indeed buggy)...like perhaps 192.168.88.0/24 to capture the whole subnet under it.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Tue Jun 24, 2014 10:04 pm

I added my other devices but they dont get the limit at speed when someone downloads something.. I tried mangles with queue trees as well no luck.. :(
You do have the parent queue in there now, right?

Try to change the parent queue to use IPs as well (since perhaps interface matching is indeed buggy)...like perhaps 192.168.88.0/24 to capture the whole subnet under it.
yes its 192.168.1.0/24

it is working now, I do not know how.
I Walk Alone
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Thu Jun 26, 2014 3:17 pm

how can I reduce the refresh rate (update period of speeds, traffic etc) to 0.5s (500ms)?
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Thu Jun 26, 2014 5:41 pm

how can I reduce the refresh rate (update period of speeds, traffic etc) to 0.5s (500ms)?
I don't think you can do that from Winbox...

From terminal, you could use the "interval" argument, and set it to "0.5".
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Sat Jun 28, 2014 11:28 pm

can you be more spesific? Its like a polling period of the traffic graph.
I Walk Alone
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: Fixing the minimum bandwidth

Sat Jun 28, 2014 11:42 pm

can you be more spesific? Its like a polling period of the traffic graph.
Pretty much, yeah, but the results are displayed inside a terminal, as opposed to a graph or a Winbox window.

Click "New Terminal", and type:
/queue simple print stats interval=0.5s
Use the arrow keyboard keys to navigate up and down the queue list (if you need to scroll that is), and press "q" when you want to stop the visualization.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Aug 04, 2014 2:05 pm

Hi again.. you know interface names are not working in simple queues.. so how can I mark wlan in-out packet with mangle? So that I can do a queue for wlan finally. :)
I Walk Alone
 
kgninfos
Member
Member
Posts: 387
Joined: Thu Jun 21, 2012 7:34 pm
Location: Earth
Contact:

Re: Fixing the minimum bandwidth

Mon Aug 04, 2014 4:32 pm

 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Mon Aug 04, 2014 4:39 pm

I would do that but my speed is not fixed.. at nights I get 15 mbps, at day I get 5 mbps... I cant change the speed all the time in the routeros for queue trees (many clicks).. but in simple queues its simple as one click.

So I will stick with simple queues for now.

edit: solved it by just creating "others" in the address of 192.168.1.0/24 subnet under the family of LAN (again its 192.168.1.0/24) :) tested it and works OK!
I Walk Alone
 
lokize
just joined
Posts: 18
Joined: Thu Jun 22, 2017 6:43 am

Re: Fixing the minimum bandwidth

Fri Jun 23, 2017 9:54 pm

I would do that but my speed is not fixed.. at nights I get 15 mbps, at day I get 5 mbps... I cant change the speed all the time in the routeros for queue trees (many clicks).. but in simple queues its simple as one click.

So I will stick with simple queues for now.

edit: solved it by just creating "others" in the address of 192.168.1.0/24 subnet under the family of LAN (again its 192.168.1.0/24) :) tested it and works OK!
how to make this others?
 
User avatar
Xtreme512
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 75
Joined: Sun Jun 08, 2014 2:43 pm
Location: Nicosia, CY
Contact:

Re: Fixing the minimum bandwidth

Thu Jul 13, 2017 10:56 pm

I would do that but my speed is not fixed.. at nights I get 15 mbps, at day I get 5 mbps... I cant change the speed all the time in the routeros for queue trees (many clicks).. but in simple queues its simple as one click.

So I will stick with simple queues for now.

edit: solved it by just creating "others" in the address of 192.168.1.0/24 subnet under the family of LAN (again its 192.168.1.0/24) :) tested it and works OK!
how to make this others?
"others" is just the name. just create the same subnet under the parent. logically, this monitors the left over IPs in that parent (subnet).
I Walk Alone

Who is online

Users browsing this forum: gkk, joegoldman, Jotne and 39 guests