Community discussions

MikroTik App
 
ttrm007
just joined
Topic Author
Posts: 2
Joined: Thu Jun 26, 2014 7:59 pm

Plex setup

Thu Jun 26, 2014 9:17 pm

I've configured a number of routers to forward to a specific computer on the local network based on incoming port. I've also ready about Nat forwarding setup on this router but can't seem to make it work for my Plex server.

I had this server working great at another location/different router.

What I've tried:

Enable UPnP - tried with allow to disable external interface checked and unchecked.

IP->firewall->NAT

enabled
chain: dstnat
protocol tcp
src port 32400
dst port 32400
in interface bridge 1 (tried all)
action dst-nat
to addresses 192.168.2.114 (plex server ip)
to ports 32400

Nothing seems to happen/work. I get message in plex setup that you can't access from outside network.

Firewall is turned off on computer.
 
eltoozero
just joined
Posts: 15
Joined: Fri Jun 27, 2014 5:16 am

Re: Plex setup

Fri Jun 27, 2014 9:41 am

Have you checked/cleared/watched your firewall counters to make sure the traffic is hitting the router like you expect?

This is much easier on a relatively "quiet" network.

You can do this from command-line or webfig, depending on your preference.

/ip firewall filter print
/ip firewall nat print

The print "follow" command is really nice for this.
 
nzjc
just joined
Posts: 1
Joined: Tue Feb 10, 2015 12:04 pm

Re: Plex setup

Tue Feb 10, 2015 12:12 pm

Hi there,

I'm using a 6.24 Mikrotik router. I just successfully got Plex working, using a simple DST-NAT as you did.

Steps:

1) Under firewall > nat, add a new rule. Mine looks like this:

(Under the assumption that my Plex PC inside my LAN is on 192.168.1.50 and my public WAN address is 80.50.40.20)

chain=dstnat action=dst-nat to-addresses=192.168.1.50 to-ports=32400 protocol=tcp dst-address=80.50.40.20 dst-port=32400 log=no log-prefix=""

2) Go into Plex Media Server

http://127.0.0.1:32400/web/index.html#!/settings/server

Then click the 'Connect' button. When you tell the server to connect, it will "phone home", allowing access from outside. Now, anyone logged in with your Plex account can access this server, while your public IP stays the same. You can troubleshoot by watching the counter on the DSTNAT rule.
 
AmsoilMan
just joined
Posts: 7
Joined: Fri Mar 28, 2014 4:39 am

Re: Plex setup

Mon Nov 27, 2017 9:39 pm

Tried adding the NAT rule but still not working on my end. Running Routerboard 6.40.5 with 3.41 firmware.
 
cubanx
just joined
Posts: 1
Joined: Mon Dec 04, 2017 12:13 am

Re: Plex setup

Mon Dec 04, 2017 12:17 am

Wow, signing up for this forum is way more difficult than it should be :)

I had the same issues as you, and I turned on UPnP to no avail.

Then, I found the Interfaces button.

I added:
1) pppoe-out1 to external
2) ether1 to internal
3) ether2-master to internal

Boom, I can see Plex from the outside...
 
smile
just joined
Posts: 1
Joined: Tue Feb 06, 2018 9:47 pm

Re: Plex setup

Thu Feb 08, 2018 7:53 am

Hi cubanx I'm sorry for maybe a stupid question but, can you explain in more details (I have the same problem). I have recently been a proud owner of such a router, but because networking & Linux are not my strength, I'm completely confused. Thank you in advance for your answer.
 
User avatar
mikrotiq
just joined
Posts: 1
Joined: Mon May 14, 2018 11:06 pm

Re: Plex setup

Mon May 14, 2018 11:31 pm

Hello, friends!
I trying to use only NAT port 32400 forwarding
add action=dst-nat chain=dstnat dst-port=32400 in-interface=pppoe \
    protocol=tcp to-addresses=192.168.10.10 to-ports=32400
and web access to plex is working, but access to plex via smart tv app didn't work.
Then i try add this rule to firewall:
add action=accept chain=forward comment=plex connection-nat-state=dstnat dst-port=32400 in-interface=\
    pppoe protocol=tcp
and plex giving to me access to server.
Please test this solution
just newbie
 
sleerf
newbie
Posts: 47
Joined: Tue Sep 13, 2016 9:12 am

Re: Plex setup

Tue Apr 09, 2019 3:47 am

Hello, friends!
I trying to use only NAT port 32400 forwarding
add action=dst-nat chain=dstnat dst-port=32400 in-interface=pppoe \
    protocol=tcp to-addresses=192.168.10.10 to-ports=32400
and web access to plex is working, but access to plex via smart tv app didn't work.
Then i try add this rule to firewall:
add action=accept chain=forward comment=plex connection-nat-state=dstnat dst-port=32400 in-interface=\
    pppoe protocol=tcp
and plex giving to me access to server.
Please test this solution
did this work for you?
 
sleerf
newbie
Posts: 47
Joined: Tue Sep 13, 2016 9:12 am

Re: Plex setup

Tue Apr 09, 2019 3:52 am

This is making me crazy. half the commands here don't even function in the Command line for some reason. either they have changed in the last year or ----hellifikknow. can this not be done through winbox?
 
User avatar
Steveocee
Forum Guru
Forum Guru
Posts: 1130
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: Plex setup

Tue Apr 09, 2019 3:51 pm

This is making me crazy. half the commands here don't even function in the Command line for some reason. either they have changed in the last year or ----hellifikknow. can this not be done through winbox?
It can easily be done through Winbox however your problem is this:
Annotation 2019-04-09 134819.jpg
How helpful is that? Does that show you the FULL rule?
My full Plex rule is as follows:
/ip firewall nat
add action=dst-nat chain=dstnat comment=PLEX dst-address-list=WAN-IPs dst-port=32400 protocol=tcp to-addresses=10.10.10.31
Even then that won't help you much so you need to amend it to suit you
add action=dst-nat chain=dstnat comment=PLEX in-interface=WANINTERFACECHANGEME dst-port=32400 protocol=tcp to-addresses=LANIPCHANGEME
You do not have the required permissions to view the files attached to this post.
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
scloutier
just joined
Posts: 5
Joined: Wed Jun 15, 2016 6:33 pm

Re: Plex setup

Wed Apr 10, 2019 10:20 pm

when the rule is properly created on the router, you need to go in plex under the settings -> remote access and check "manually specify public port" and put in 32400. Once you have this configured it should work.
 
sleerf
newbie
Posts: 47
Joined: Tue Sep 13, 2016 9:12 am

Re: Plex setup

Fri Apr 26, 2019 4:50 am

this doesn't work for me at all. I entered the WAN interface as the static IP of the router itself and the LAN as the internal IP my machine has connected to the router. ie |

/ip firewall nat add action=dst-nat chain=dstnat comment=PLEX in-interface=71.XX.XX.XX dst-port=32400 protocol=tcp to-addresses=10.10.X.X

I get a message "input does not match any value of the interface"
 
Sob
Forum Guru
Forum Guru
Posts: 6517
Joined: Mon Apr 20, 2009 9:11 pm

Re: Plex setup

Fri Apr 26, 2019 4:58 am

That's not really unexpected, when the parameter is in-interface=<name of interface>. You're probably looking for dst-address=<IP address>.
Excessive quoting is useless and annoying. If you use it, please consider if you could do without it.

Who is online

Users browsing this forum: abrar226, matiss, stefki and 136 guests