Community discussions

MikroTik App
 
rebel2234
newbie
Topic Author
Posts: 42
Joined: Sat May 20, 2006 6:23 am

HotSpot and Playstation 4

Mon Sep 29, 2014 12:41 am

Physical set up is like this.

Mikrotik(AP/Hotspot/Transparent proxy unchecked)~~~~~>Customer CPE(bridged)----->Customer Router(public IP, Dmz'd to PS4)------>PlayStation 4

~~~ = Wireless
---- = Wired

What happens is the customers PS4 can sign into the playstaion network fine but when joining online multiplayer games most of the time will not join the game and will spit an error message saying something like "Cannot connect to server. You may have signed in at a different location. Sign out and sign in again". We have had this happen with a few customers now and only seems to effect PlayStation 4's all other systems seem to work Xbox360, Xbox1, Playstation 3 etc.

What I can do to fix this is just make a binding for them in hostpot and bypass their Public IP and then they have no problems at all. But I would have to do this for everyone who owns a PS4 and it becomes a lot of micro-management. So with this logic there is something in the hotspot end of things that is causing me greif. I'm sure there is something I should be able to do in the firewall to mitigate this but not sure what to do.

Has anyone else had this problem?
Any ideas on what could be causing the problem?
Any ideas on a firewall rule's I could try?

Thanks,
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: HotSpot and Playstation 4

Mon Sep 29, 2014 12:52 am

You could set up a PPPoE server in addition to the hotspot server. Then make routers connect using that.

In that fashion, you still get the benefit of having a username and password for the client, while still allowing them to not enter their password every time, which is what's really bothering the PlayStation.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
rebel2234
newbie
Topic Author
Posts: 42
Joined: Sat May 20, 2006 6:23 am

Re: HotSpot and Playstation 4

Mon Sep 29, 2014 1:04 am

Using MAC authentication and RADIUS. They are not being timed out or signed out.
 
rebel2234
newbie
Topic Author
Posts: 42
Joined: Sat May 20, 2006 6:23 am

Re: HotSpot and Playstation 4

Mon Sep 29, 2014 2:14 am

May have answered my own post thanks to >this< post. Added the following code. Checked with one customer and seemed to have fixed the problem will talk to the others.

Export:
/ip firewall nat
add chain=pre-hotspot dst-address-type=!local hotspot=auth
add action=return chain=pre-hotspot
Print:
1   chain=pre-hotspot action=accept dst-address-type=!local hotspot=auth 

2   chain=pre-hotspot action=return

Who is online

Users browsing this forum: bCDnO, rdelacruz, Zacharias and 147 guests