Community discussions

MUM Europe 2020
 
Tranthom
just joined
Topic Author
Posts: 7
Joined: Mon Sep 05, 2011 7:52 am

Xbox360 NATing imposible on RB750UP with V6.22

Wed Dec 03, 2014 7:39 am

Hi

I'm a total newbie with mikrotik. I have a RB750UP with V6.22 . I'm unable to obtain a suficent NATing for my xbox360 to fully work on xbox live . my setup is quite simple. Cable modem is in port 1, port 2 is going to a cisco 2924 switch and from there I'm going to my XBOX360. My xbox have a static IP address 192.168.1.36 my whole network is 192.168.1.x/24. Internet is working fine. only my Xbox is bugging me. everything was fine before switching from mu WRT54gs to this mikrotik.

I found some other post on many sites that are giving me some command lines to add in order to make it work because it seems a general problem with XBOX LIVE but I can't find WHERE to insert them in the router nor understand how they work.

I would really appreciate an easy HOWTO step-by-step please.

thanks
 
error216216
newbie
Posts: 25
Joined: Fri May 23, 2014 2:07 am

Re: Xbox360 NATing imposible on RB750UP with V6.22

Thu Dec 04, 2014 3:27 am

Ok, first you have to open the router's page by writing the ip address of the router in the address bar of your browser, I assume it's 192.168.1.1, you can find it by looking at what gateway any device gets from dhcp. Then click on WInbox and a program will download, after that fill the connect to with the same ip that you put in your browser, username is by default admin and no password, then click connect.
In the new window click on New terminal (on the left) and another window will apear inside the current window, select all the code bellow(all of it not just bits) copy it (CTRL+C) and paste it the terminal window(right click and paste, DO NOT USE CTRL+V IN TERMINAL!! ).

If you have not modified the names of the interfaces it should work. It is made aspecially for you! on IP 192.168.1.36.
/ip firewall filter
add chain=input in-interface=ether1-gateway protocol=tcp port=80 place-before=0
add chain=input in-interface=ether1-gateway protocol=udp port=88 place-before=0
add chain=input in-interface=ether1-gateway protocol=tcp port=53 place-before=0
add chain=input in-interface=ether1-gateway protocol=udp port=53 place-before=0
add chain=input in-interface=ether1-gateway protocol=tcp port=1863 place-before=0
add chain=input in-interface=ether1-gateway protocol=udp port=1863 place-before=0
add chain=input in-interface=ether1-gateway protocol=tcp port=3074 place-before=0
add chain=input in-interface=ether1-gateway protocol=udp port=3074 place-before=0
add chain=input in-interface=ether1-gateway protocol=tcp port=3075 place-before=0
add chain=input in-interface=ether1-gateway protocol=udp port=3075 place-before=0
add chain=forward in-interface=ether1-gateway protocol=tcp port=80 place-before=0
add chain=forward in-interface=ether1-gateway protocol=udp port=88 place-before=0
add chain=forward in-interface=ether1-gateway protocol=tcp port=53 place-before=0
add chain=forward in-interface=ether1-gateway protocol=udp port=53 place-before=0
add chain=forward in-interface=ether1-gateway protocol=tcp port=1863 place-before=0
add chain=forward in-interface=ether1-gateway protocol=udp port=1863 place-before=0
add chain=forward in-interface=ether1-gateway protocol=tcp port=3074 place-before=0
add chain=forward in-interface=ether1-gateway protocol=udp port=3074 place-before=0
add chain=forward in-interface=ether1-gateway protocol=tcp port=3075 place-before=0
add chain=forward in-interface=ether1-gateway protocol=udp port=3075 place-before=0
/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=80
add chain=dstnat protocol=udp dst-port=88 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=88
add chain=dstnat protocol=tcp dst-port=53 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=53
add chain=dstnat protocol=udp dst-port=53 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=53
add chain=dstnat protocol=tcp dst-port=1863 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=1863
add chain=dstnat protocol=udp dst-port=1863 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=1863
add chain=dstnat protocol=tcp dst-port=3074 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=3074
add chain=dstnat protocol=udp dst-port=3074 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=3074
add chain=dstnat protocol=tcp dst-port=3075 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=3075
add chain=dstnat protocol=udp dst-port=3075 in-interface=ether1-gateway action=dst-nat to-addresses=192.168.1.36 to-ports=3075
#END OF SCRIPT IN CASE YOU FORGET TO PRESS ENTER AT LAST LINE
I have tested this on a 750U and it works only I used different subnet. Make shore your xbox network settings are correct.
You can see these rules and modify them in winbox at IP-> firewall -> filters rules and nat
 
Tranthom
just joined
Topic Author
Posts: 7
Joined: Mon Sep 05, 2011 7:52 am

Re: Xbox360 NATing imposible on RB750UP with V6.22

Mon Dec 08, 2014 8:40 am

thanks for this info

I did it but my xbox keep telling me that the natting is not sufficent :(
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: Xbox360 NATing imposible on RB750UP with V6.22

Mon Dec 08, 2014 9:24 am

These rules are really insecure. I would not recommend this as you are opening the most common attack ways.
 
jfvelamoscoso
Trainer
Trainer
Posts: 59
Joined: Fri Oct 25, 2013 12:52 am
Location: Arequipa - Peru

Re: Xbox360 NATing imposible on RB750UP with V6.22

Tue Dec 09, 2014 6:55 pm

Please enter to you router using telnet / ssh or on terminal tab of winbox/web. Type /export and copy your result here.
----------------------------------------
jfvelamoscoso@gmail.com
Network Engineer Noc Department
MTCNA, MTCTCE

If it helps please give some karma
 
plankanater
Member Candidate
Member Candidate
Posts: 167
Joined: Wed Mar 14, 2012 3:56 am

Re: Xbox360 NATing imposible on RB750UP with V6.22

Fri Jan 23, 2015 6:07 pm

The best way to get around strict Nat on a Xbox is to enable upnp. It is under the IP list. Once you enable it you will have to enter in the Outside and inside interfaces. We run hot-spots with hundreds of Xboxes behind a single router. Programming static Nat rules would be a nightmare. Upnp is the way to go.

Note: UPNP will not work if the router is behind another Nated router not running upnp or without an open nat table.

Who is online

Users browsing this forum: Google [Bot] and 34 guests