Community discussions

 
Wam88
just joined
Topic Author
Posts: 2
Joined: Fri Dec 12, 2014 4:07 am

Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Fri Dec 12, 2014 4:33 am

Hi ,

I've got my new setup...really new as I'm a total novice at this. I really want a killer LAN (951) with the groove pulling in wifi signals from wherever I can get free wifi. I've installed the groove to act as an outside antenna and the 951 for all my wifi devices to connect to.

I've read thru some of these boards but don't really understand the in's and out's of what I need to do right out of the box.

About all I've been able to figure out is how to update both of the devices software to the latest version. From what else I've read, I can see that I need to put the groove in CPE mode and the 951 in home AP mode, but my limited knowledge ends there.

Any help for the less than tech savvy would be gratefully appreciated.

WAM
 
edakira
just joined
Posts: 3
Joined: Sat Apr 11, 2015 12:56 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Sat Apr 11, 2015 1:05 am

Hi ,

I've got my new setup...really new as I'm a total novice at this. I really want a killer LAN (951) with the groove pulling in wifi signals from wherever I can get free wifi. I've installed the groove to act as an outside antenna and the 951 for all my wifi devices to connect to.

I've read thru some of these boards but don't really understand the in's and out's of what I need to do right out of the box.

About all I've been able to figure out is how to update both of the devices software to the latest version. From what else I've read, I can see that I need to put the groove in CPE mode and the 951 in home AP mode, but my limited knowledge ends there.

Any help for the less than tech savvy would be gratefully appreciated.

WAM

WAM, I have an identical challenge. I have the exact same hardware and am currently on a boat in Isla Mujeres Mexico and I cannot figure this system out as I install. Is there any way I could speak to you if you were able to resolve? Any help would be much appreciated. I have spent hours trying to configure this. Thanks --Ed
 
User avatar
Breizh
just joined
Posts: 1
Joined: Sun Jul 26, 2015 6:43 pm
Location: Cork
Contact:

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Mon Jul 27, 2015 1:11 am

Hi Guys, not sure if you ever got sorted, but as there may be others with the same issue here is how to set up your GrooveA 52HPn and an AP. Just for the record here is my hardware list:
  1. Antenna: 2.4GHz 12dBi Outdoor Omni-directional Antenna TL-ANT2412D
  2. External Wifi AP: MicroTik GrooveA 52HPn
  3. Internal Wifi AP: 150Mbps Wireless N Nano Router TL-WR702N
  4. PoE Adapter: MaxLink Passive Redundant Industrial PoE adapter APOE03
  5. Cable: CAT5 STP 1 x 10m, 1 x 1m
Groove Router Setup:
  • Connect up your Groove to the omni arial feed back the CAT5 cable to the desired end location.
  • Connect the PoE adapter to your power supply, (12v DC)
  • Connect your 10m CAT5 cable from the Groove into the PoE adapter 'Power' port.
  • Connect one end of the 1m CAT5 cable into the 'Data' port of the PoE adapter and the other end into your computer
  • Disable your WiFi on your COMPUTER
  • Give your 'Wired' ethernet adapter on your COMPUTER the following IP address:
    • IP Address: 192.168.88.2
      Subnet Mask: 255.255.255.0
      Gateway: 192.168.88.1
      DNS: 192.168.88.1
  • Now open up a browser, Internet Explorer or Firefox etc. and type in the following in the address bar:
  • You will be presented with the Webfig page of the Groove, now the serious work commences...
  • We will now configure the Groove, nothing fancy... Click on the top left menu option called 'Quick Set'
  • Now click on the small drop down menu on the top far right and choose CPE
  • Under the 'Configuration' heading on the right, we want to be in 'router' mode, so click the radio option 'Router'
  • Under 'Wireless Network' heading, the 'Address Acquisition' must be 'Automatic' click the radio button to select this
  • Under the 'Local Network' heading The `IP Address needs to be
    • IP Address: 192.168.88.2
      Subnet Mask: 255.255.255.0/24
  • Next, you must enable NAT by selecting NAT option, a tick will appear
  • Now we can press the 'Apply Configuration' button
  • Now select the DNS menu option halfway down on the far left
  • Next to the Servers option click the little black down arrow and add the following address: 8.8.8.8
  • Add a second Server address by clicking the next little black down arrow and add the following address: 208.67.222.222
  • Place a tick in the option 'Allow Remote Requests' and then click the 'apply' button at the top
  • Now return to the 'Quick Set' menu option and select the required WiFi from the list on the left side of the main page
  • You will now be asked for a password if one is required, enter this and then click the 'connect' button
  • You should now be connected an an IP address should appear after a few seconds or so on the right under the 'Wireless Network' heading. You are now ready to configure your AP
  • Remove the other end of the CAT5 cable from your PoE adapter, leave the PC plugged in, and plug the other end into the 'WAN' port of your AP
  • You will now need to configure your computers IP address again according to the instructions from your AP supplier. See next steps (general)
AP setup:
  • Follow the manufacturers instructions regarding connecting to your AP for the first time and configure your computer. You will need to use the 1m CAT5 cable now, one end plugged into the AP and the other into your Computer
  • Enable the router/AP as a an Access Point (AP)
  • Give it a STATIC IP address:
    • IP Address: 192.168.88.3
      Subnet Mask: 255.255.255.0
  • Now you need to configure the AP as a DHCP SERVER, use the following settings (generic):
    • DHCP Server: Enable
      Start IP Address: 192.168.88.10
      End IP Address: 192.168.88.60 (this will give you 50 IP addresses, if you require more make the final octet 60 to a higher number to a MAX of 253)
      Address Lease Time: leave as standard
      Default Gateway: 192.168.88.1
      Default Domain: (optional)
      Primary DNS: 8.8.8.8
      Secondary DNS: 208.67.222.222
  • Now set up the Wireless by giving a name to your network, (SSID)
  • The settings should be good out of the box
  • The WifI password needs to be set, either use the one on the AP itself or choose a MEMORABLE one
  • Apply the settings, plug the CAT5 cable out of your computer and into the PoE adapter 'Data' port
  • Turn on your WiFi on your computer and connect onto your new WiFi network... enjoy
Changing Base WiFi

If you need to choose a different WiFi AP when you arrive at a different port etc. just open up a browser to the Groove (192.168.88.1) whilst connected to your own WiFi link and then 'disconnect' from the previous WiFi link, and choose a new WiFi, add the password again, and 'Connect' and off you go again...

I hope this helps anybody who gets stuck configuring the routerBoard GrooveA 52HPn.

Enjoy..

Breizh 8)
Laid back takin' it easy... well sometimes! 8)
 
plisken
Forum Guru
Forum Guru
Posts: 2388
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Wed Jul 29, 2015 9:56 am

Hi ,

I've got my new setup...really new as I'm a total novice at this. I really want a killer LAN (951) with the groove pulling in wifi signals from wherever I can get free wifi. I've installed the groove to act as an outside antenna and the 951 for all my wifi devices to connect to.

I've read thru some of these boards but don't really understand the in's and out's of what I need to do right out of the box.

About all I've been able to figure out is how to update both of the devices software to the latest version. From what else I've read, I can see that I need to put the groove in CPE mode and the 951 in home AP mode, but my limited knowledge ends there.

Any help for the less than tech savvy would be gratefully appreciated.

WAM
First question: do you want to connect to an AP with the groove?
 
okengr
just joined
Posts: 1
Joined: Wed Oct 28, 2015 5:01 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Wed Oct 28, 2015 5:21 am

Hi,

I have the identical set up to the original post, and was helped a lot by the post by Breizh. However, since his AP was not a Mikrotik the last section didn't correspond exactly to what I'm seeing.

So I have a couple of questions:
1. On item 13. of his post he says to give the Groove an IP of 192.168.88.2. This would be same address as the PC and would leave the system with no 192.168.88.1 address. Should the Groove be addressed as 192.168.88.1 instead?

2. Under the AP setup section, when doing this for the Mikrotik router specified in the original post should it be set up as Wisp AP or Home AP?

3. Should the AP Internet section be static or automatic? Seems it should be static with the IP of the Groove ...88.1. If this is the case what IP should be entered under the Local Network section?

4. What should be entered for the Firewall?

5. Is there anything else that should be set to keep the system secure other than a password under the Wireless Security Profile?

Thanks for your patience and help!
okengr
 
plisken
Forum Guru
Forum Guru
Posts: 2388
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Thu Oct 29, 2015 9:28 pm

Reset the groove without default config.
Try this configuration.

Edit the SSID to the SSID from the hotspot.
Edit country settings
Edit also the CPU speed if you have another Groove model at 400 MHz CPU


/interface wireless
set [ find default-name=wlan1 ] antenna-gain=5 country=belgium l2mtu=1600 ssid="EDIT SSID"
/ip address
add address=192.168.100.1/24 interface=ether1 network=192.168.100.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=wlan1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip dns static
add address=192.168.100.1 name=groove-client
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1
/system leds
set 0 interface=wlan1
/system routerboard settings
set cpu-frequency=600MHz
/tool romon port
add




I hope this helps you
 
raymacke
just joined
Posts: 1
Joined: Sun Nov 09, 2014 3:04 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Tue Jun 14, 2016 9:21 pm

Breizh's post above did not work for me but with some modification I did get my system to work. I have a Groove 52PHN and a RB951.  On my boat I wanted the Groove to scan for hotspots . Once I select the hot spot I want the RB951 is used as an access point so my wireless devices can connect to the hotspot. Note - the steps listed do tend to change somewhat with different versions of the firmware but the basics stay the same. I am including some very basic steps for US that are new to all of this. Here is my step by step setup of the two -

NOTE : It is best to configure each device separately before connecting the Groove to the RB951.  Initially  Each device will need to be connected by an Ethernet cable to your laptop or desktop.  The Groove will need to be powered with the included Y cable and AC adapter. Plugged the male end of the Y's Ethernet cable into your home computer system and use a patch cable to connect the Groove. When setting up the RB951 The cable runs straight from the home computer to the device. I had no luck using Port #1 (I have no idea why) but Port #2 worked fine.

Groove Router Setup: (Antenna) WebFig v6.35.2

Groove must be powered by POE
  1. Open up a browser and type in the following in the address bar: http://192.168.88.2/webfig/      
  2. Click on the top left menu option called 'Quick Set'
  3. Click on the small drop down menu on the top far right and choose CPE
  4. Under the 'Mode' heading on the right select 'Router' mode.
  5. Under 'Wireless Network' heading, the 'Address Acquisition' must be 'Automatic'.
  6. Under the 'Local Network' heading set the IP Address to
    • IP Address: 192.168.88.2      Subnet Mask: 255.255.255.0/24
  7. Now configure the Router as a DHCP SERVER, use the following settings:
    • DHCP Server:    Enable  -   Start IP Address: 192.168.88.10      End IP Address: 192.168.88.254       Enable NAT by selecting NAT option
  8. Now we can press the 'Apply Configuration' button at bottom right
  9. Now select the IP menu option halfway down on the far left and select DNS
  10. Next to the Servers option click the little black down arrow and add the following address: 8.8.8.8
  11. Add a second Server address by clicking the next little black down arrow and add the following address: 208.67.222.222
  12. Place a tick in the option 'Allow Remote Requests' and then click the 'apply' button at the top
  13. Now return to the 'Quick Set' menu option and select the WiFi hotspot from the list on the left side of the main page
  14. You will now be asked for a password if one is required, enter this and then click the 'connect' button
  1. You should now be connected an an IP address should appear after a few seconds or so on the right under the 'Wireless Network' heading.
AP setup: (RB951 Router) WebFig v6.35.4
  1. Use a CAT5 cable to connect the AP (RB951) to your computer.
  2. Enable the router/AP as a an Access Point (AP or WISP AP)
  3. Set mode to Route
  4. Set a STATIC IP address:
    • IP Address: 192.168.88.3/32   Netmask 255.255.255.0   Default Gateway: 192.168.88.2  
  1. Now set up the Wireless by giving a 'Network Name', (SSID) like - MikroTik RB951
  2. LAN IP Address 192.168.88.3(/24)
    Netmask 255.255.255.0(/24)
  3. NO DHCP SERVER
  4. Check NAT
  5. Set WIFI password.
  6. Shut down and attach Groove to RB951. For Groove to pull power from the RB951 the cable must be in Port 5 which supplies POE.
  7. On your wireless device the new wireless AP should now show. Make a connection to that network.
  8. Then in a browser on your wireless device type - 192.168.88.2 in the location bar. WebFig should open. It may take a moment to propagate but in the center left you should see a list of the available WIFI hotspots being “seen” by the Groove. Select the desired one and enter the password if needed. Press 'Connect'. After a moment you should see an IP address and other items appear in the upper right. The network should now be active.
  9. If you want to see the configuration for the RB951 enter - 192.168.88.3 in the browser and enter WebFig for it.
  10. Once everything is working go to WebFig for each device and look down the left menu and find 'FILES'. Open it and save a copy of the configuration. These backups can be restored at a later date if a problem develops.
Hope this works for you. I spent hours and hours sorting through this but I am a total noob on this type of setup.
 
K79
newbie
Posts: 29
Joined: Sun Jan 08, 2017 4:39 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Fri Feb 17, 2017 9:32 am

Hi Guys, not sure if you ever got sorted, but as there may be others with the same issue here is how to set up your GrooveA 52HPn and an AP. Just for the record here is my hardware list:.....
Is there a way to reset the GrooveA 52hpn without physically touching it? I cannot winbox into it at even even using MAC fails. Find pic attached
You do not have the required permissions to view the files attached to this post.
 
plisken
Forum Guru
Forum Guru
Posts: 2388
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Fri Feb 17, 2017 12:26 pm

Try first with older Winbox
 
K79
newbie
Posts: 29
Joined: Sun Jan 08, 2017 4:39 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Thu Mar 09, 2017 5:16 pm

Try first with older Winbox
Winbox does not 'see' it. Yes even through MAC. Netinstall seems not to work on windows 10
 
plisken
Forum Guru
Forum Guru
Posts: 2388
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Thu Mar 09, 2017 9:00 pm

Try Winbox 2.2.18
 
Jude
just joined
Posts: 1
Joined: Sun Feb 18, 2018 7:51 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Sun Feb 18, 2018 7:57 pm

To raymacke:
I have a Linksys wireless dual band router. Can I connect this to the MikroTik Groove A52 AC Model?
Real newbie and any assistance much appreciated. Thanks
 
Laservideo
just joined
Posts: 1
Joined: Wed Mar 07, 2018 3:16 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Wed Mar 07, 2018 5:16 am

I have a Metal 52 AC and hap AC. I got them working with the above advice but the WiFi response was slow. I removed the hap and setup the Metal as station for receiving WiFi and also an AP from the same Metal and it is working fine. However, I can log into the Metal with Winfig but when I click the disconnect button, the program locks up and does not scan for new WiFi locations. The only way I have found to change the WiFi location I want to log into is to connect the Metal Ethernet cable into my computer and run Winbox. That does work. I am using a MacBook Pro and must boot into Bootcamp with windows 7 pro 64 bit. I am hoping to find a way to log into new campgrounds with our iPads from WiFi into Winfig and not necessarily have to bring my MacBook and run Windows. Any assistance would be appreciated.
 
AdAstra
just joined
Posts: 1
Joined: Sun Mar 11, 2018 7:37 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Sun Mar 11, 2018 7:49 am

Hi All,

I’m a complete novice so I’d appreciate your advice, and patience. I’m setting up my Groove with a TP-link archer c7 router to use the marina WiFi on my boat. I seemed to have done at least a couple of things right following a mix of the above directions, but I’m still a little lost.

I think I’ve managed to setup the archer c7 as an access point, and when I connect to it I can connect to the groove through Winbox and the MAC address.

However, when I select my marina’s WiFi network I still don’t have WiFi. My marina uses individualized codes that you enter in the browser after you connect to access their WiFi, and I’m guessing this has something to do with the problem? I can’t find any way to enter that code.

Any advice would definitely be appreciated.

Thanks!
 
Jorge
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Mon Jun 12, 2017 10:27 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Sat Jun 30, 2018 3:32 am

@ laservideo
Hi, a bit late I guess...
I have exactly the same problem with a RBGrooveA-52HPn. Once I disconnect, I loose the connection. As you do, I connect my macbook pro to get it work again. But there is a little prog that permit you to use Mac OSX without bootcamp, maybe wine? Anyhow you can open Safari to manage your device, you don't have to use windows isn't it?
Sorry I can't check, my mac is not working currently. I found a way around. I connect the groove to an airport station, it makes the same as a mac. To save energy(I am in a boat)
I ordered last week a little router that runs on 5,5 volts, that will make the job(hAP Lite RB941)
I hope this helps a bit...
Last edited by Jorge on Sat Jun 30, 2018 4:20 am, edited 2 times in total.
 
yevpro
just joined
Posts: 14
Joined: Sun Feb 05, 2017 9:12 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Wed Aug 01, 2018 6:07 pm

Hi sailors. I have similar setup (mikrotik groove + hap ac lite) on our boat.
I can help you with setting up your wifi system. Everything is pretty simple. Post questions here and i will try to help.
 
wintermute42
just joined
Posts: 1
Joined: Mon Aug 27, 2018 6:53 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Mon Aug 27, 2018 7:04 am

Hi sailors. I have similar setup (mikrotik groove + hap ac lite) on our boat.
I can help you with setting up your wifi system. Everything is pretty simple. Post questions here and i will try to help.
Yevpro, I finally created an account here just to take you up on your offer :D I've been messing with this for far too long long and am guessing that I'm missing some pretty simple points that will get everything working smoothly.

My set up is a Groove AC -> Apple AirPort Extreme (broadcasting WiFi to boat). That said, I would love to even just get the Groove working directly plugged into my MacBook Pro as a proof of life.

So far, I've been able to follow the instructions in this thread and got the Groove to connect to an Xfinity SSID nearby. Even though I am able to get the Groove connected to the wifi network, I am not able to load any web pages on the laptop that is directly connected to the Groove. I am assuming that I should be able to. I was hoping to have that test working before moving on to setting up my Airport. Is that reasonable?

As a note, I am using the net config for setup.

Thanks in advance, soooo much!
 
User avatar
w32pamela
Member Candidate
Member Candidate
Posts: 112
Joined: Fri Jul 12, 2013 4:22 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Tue Aug 28, 2018 6:34 pm

Your Groove will work when connected directly to your computer ethernet port if the Groove is correctly configured as a CPE. I have attached the default configuration file from a Groove 52ac with a level 3 license. This license only allows the Groove to act as a CPE so this type of Groove would work for you out of the box.

The configuration is from a Groove running routerOS v6.42.7 with the system->routerboard also updated. You should do these updates before installing the configuration. I have changed the default band to 2ghz-bgn so that the Groove will scan for 2.4ghz signals rather than 5ghz which is the default in the newer routerOS versions. I have also added a 15 second delay at the beginning of the file.

You should be able to use your Groove directly with your computer or plug it into the WAN port of your router and use it. Your router WAN should be set to get its internet settings automatically from the Groove.

If you aren't already familiar with Winbox I would download it and learn to use it when working with a Mikrotik device. Other picking and connecting to access points you should not make changes on the Quick Set page.
config.rsc
To install the configuratin:
1. file move it into the flash folder in files. If it is not in the flash folder it will be deleted during the reboot of the Groove and configuration will fail, On a PC running Winbox you can drag and drop the file into "flash". That may work with a Mac but I'm not sure.
2. Go to System>Reset Configuration
3. check mark "No Default Configuration" and "Do Not backup"
4. Open the Run After Reset box and select "config.rsc" then click the Reset Configuration button. Allow 60 seconds for the process to complete.

The Groove should be accessible at 192.168.88.1. Make sure your computer is set to get its ethernet settings by DHCP
You do not have the required permissions to view the files attached to this post.
 
nomadphoto
just joined
Posts: 1
Joined: Wed Sep 19, 2018 1:02 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Wed Sep 19, 2018 1:06 pm

Hello fellow Sailors,

I just received my Groove AC and I'm struggling. What I want to do is simple. I want it connected directly to the ethernet port of my laptop (MacBook pro) and get a better signal from the marina. So far I have managed to mess around with all the different settings in the CPE and by changing the Ghz I end up seeing the network I want to connect to. However when I try to connect, it connects for a second then disconnects, then reconnects and so on and so forth. What I am missing ? Lots I can imagine.

If anyone can sort me out, I need to work and I need my connection !

Cheers
 
plisken
Forum Guru
Forum Guru
Posts: 2388
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Wed Sep 19, 2018 3:14 pm

Go first to "new terminal" type "export" and copy and paste the result in this forum.
So we can see what you are doing.
Greatings
 
User avatar
w32pamela
Member Candidate
Member Candidate
Posts: 112
Joined: Fri Jul 12, 2013 4:22 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Wed Sep 19, 2018 4:40 pm

However when I try to connect, it connects for a second then disconnects, then reconnects and so on and so forth. What I am missing ? Lots I can imagine.
If the Status line on the Quick Set page is oscillating between "Searching for Network" and "Connected to ESS" this is most commonly caused by an incorrect wifi password. Assuming your configuration is correct otherwise.
 
zabbaskeema
just joined
Posts: 6
Joined: Mon Feb 04, 2019 3:45 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Thu Feb 14, 2019 3:03 pm

This drives me crazy :)

The Groove was setup as CPE/router, connected to a wifi network.

The terminal of the groove even pings google ok.

The Groove ethernet is connected in ether5 of an HAP ac and this is where it goes sour.

No matter how I change the bridge, nat, routing, making ether5 a WAN port I cant seem to be able to have a proper return route to the Groove52.

I can ping back the Groove from the HAP ac of course.

What am I missing?

Can anyone share their configuration? I want people connecting to the HAP ac to have wifi connectivity - of course :)

Many thanks!!

Patrick
 
mkx
Forum Guru
Forum Guru
Posts: 2453
Joined: Thu Mar 03, 2016 10:23 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Thu Feb 14, 2019 5:11 pm

Post /export hide-sensitive from both devices and we'll have a look.
BR,
Metod
 
zabbaskeema
just joined
Posts: 6
Joined: Mon Feb 04, 2019 3:45 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Sun Feb 17, 2019 10:25 am

Hi people, I finally got my setup working!!!

Image

The setup is to have the Mikrotik Groove52 connected to the PPOE ether5 port on the Mikrotik HAP ac.

The scenario is to get a weak wifi signal at the Marina and make it stronger through the Groove52.
Then make it possible for people on the boat to access that internet AP through the local AP provided by the HAP ac.

eg. Marina weak signal (most of the time!) -> Groove52 -> HAP ac -> local devices via local wifi.

I spent too many hours on this so if my experience can help someone, then it is worth it!

Here is my Groove52 setup, it was the easiest thing.
Note that I do not have ethernet on my laptop, I was lucky enough that the groove had its AP setup initially so I connected to 192.168.88.1 on it and immediately changed it to 192.168.88.2.
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country=malaysia disabled=no frequency=auto mode=station-pseudobridge ssid=Manua wireless-protocol=nv2-nstreme-802.11
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.100
/ip dhcp-server
add address-pool=dhcp name=dhcp1
add address-pool=dhcp disabled=no interface=ether1 name=dhcp2
/interface bridge port
add comment=defconf interface=ether1
add comment=defconf disabled=yes interface=wlan1
/ip address
add address=192.168.88.2/24 interface=ether1 network=192.168.88.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=wlan1
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.3 netmask=24
add address=192.168.99.0/24 gateway=192.168.99.5 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,208.67.222.222
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1
/system clock
set time-zone-name=Asia/Kuala_Lumpur
/system identity
set name="MikroTik Groove52A"
Then simply fire up the HAP ac and connect to 192.168.88.1
Here is the working config for the HAP ac:
# feb/17/2019 15:35:51 by RouterOS 6.43.12
# software id = W6ST-UE2A
#
# model = RouterBOARD 962UiGS-5HacT2HnT
# serial number = 8A7C08C59608
/interface bridge
add admin-mac=CC:2D:E0:E8:10:BB auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-E810C1 wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-XXXX disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-E810C0 wireless-protocol=802.11
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
add bridge=bridge disabled=yes interface=ether1
/interface list member
add comment=defconf interface=bridge list=LAN
add interface=ether5 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0
add address=192.168.88.3/24 interface=ether3 network=192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=8.8.8.8,208.67.222.222 gateway=192.168.88.3 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,208.67.222.222
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat out-interface-list=WAN
/ip route
add distance=1 gateway=192.168.88.2
/system clock
set time-zone-name=Asia/Kuala_Lumpur
/system lcd
set contrast=0 enabled=no port=parallel type=24x4
/system lcd page
set time disabled=yes display-time=5s
set resources disabled=yes display-time=5s
set uptime disabled=yes display-time=5s
set packets disabled=yes display-time=5s
set bits disabled=yes display-time=5s
set version disabled=yes display-time=5s
set identity disabled=yes display-time=5s
set bridge disabled=yes display-time=5s
set wlan1 disabled=yes display-time=5s
set wlan2 disabled=yes display-time=5s
set ether1 disabled=yes display-time=5s
set ether2 disabled=yes display-time=5s
set ether3 disabled=yes display-time=5s
set ether4 disabled=yes display-time=5s
set ether5 disabled=yes display-time=5s
set sfp1 disabled=yes display-time=5s
This is what worked for me and actually in the end I do not even use the ether5 as a WAN port and I disabled the 192,168.88.1 IP/interface altogether.

One last comment : right after I got all pings/traceroute/DNS sorted out, I was thinking that its all good. But no of course. Google.com would work blazing fast, youtube as well! But Inbox by google or facebook would simply not show with a timeout. I had to disable the firewall on the HAP ac and voilà!! All working and with great speed if you can see the picture at the top (19/14 MBps from a distant wifi!)

Hope this helps and don't despair :)
 
Xerek
just joined
Posts: 2
Joined: Sun May 12, 2019 6:19 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Sun May 12, 2019 6:33 am

I'm jumping into this thread because I've been trolling for the past week working on configuring my Groove and hAP but keep running into trouble. I keep narrowing down the scope of what I can get to work and what I can't. I now have the Groove connected via cat5 direct to my computer and the Groove is connected to a wireless SSID. I've tried connecting to two different SSIDs with different both failing results. I've also tried setting up the Groove as a pure bridge and with a DHCP server and second internal NATd network.

Wifi SSID #1: Is my home LAN and the wireless router sending out wifi signal. I know the password to this router and can connect and ping 8.8.8.8 successfully (from the Router itself). My computer can ping through the Groove into the router on the other side, but can't get past that point. I read somewhere that certain APs don't support L2 access. I'm guessing that my laptop is in an L2 relationship with the internet through the GRoove and the other wifi router. Happy to hear if this is a technical limitation and I'll stop trying ot make it work...though it does limit the reason I purchased the Groove to grab and boost access to wifi APs.

WIFI SSID #2: This is a wifi AP which requires you to add information in a browser to login. There is no direct password to the network. If I connect directly to this SSID from my laptop, when I try to go anywhere, I am redirected to their login page, enter credentials and am then granted access. Through the Groove, I can ping the SSID router gateway from my laptop but I am not being redirected or allowed to login to their network. I haven't seen a response that addresses this particular issue though I've seen others ask it before. I imagine this is fairly common and so I hope I'm doing something wrong in the configuration and this should be possible to set up and connect.
 
User avatar
w32pamela
Member Candidate
Member Candidate
Posts: 112
Joined: Fri Jul 12, 2013 4:22 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Mon May 13, 2019 4:23 pm

see post #18 above for a default configuration for a Groove 52hpn or a Groove 52ac. Run this configuration to configure your groove as a cpe. It will display 2.4ghz signals in the scan window. The IP address will be 192.168.88.1

If it doesn't run then let me know what happened.

To get more help you should post a configuration. There are several posts above that explain how to do that.

Your SSID #2 problem will usually be solved by making your first URL request to a non-encrypted website like "http://www.example.com". You won't get any response though until you can get internet access through the Groove.
 
TomHalfmoon
just joined
Posts: 2
Joined: Thu May 16, 2019 3:25 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Thu May 16, 2019 7:12 am

Greetings
Thanks in advance for any assistance.
I currently have a Ubiqiti Bullet 2.4 mghz to Netgear Nighthawk Router working. I decided to try the Groove 52 HPacn to access 5 & 2.4 bands.

I am struggling to get the Groove to connect up to our marina WIFI. Initial setup the Groove is connected direct the WIN 10 laptop Ethernet port. I have tried to setup the Groove following the various configurations posted previously. See attached screen shots WIFI 1 Wifi 2 of setup. I see the Marina WIFI but I am not getting an IP address and not getting a connection.

What an I doing wrong.

THanks
You do not have the required permissions to view the files attached to this post.
 
User avatar
w32pamela
Member Candidate
Member Candidate
Posts: 112
Joined: Fri Jul 12, 2013 4:22 pm

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Fri May 17, 2019 6:27 pm

Tom,

You have various problems in your .docx attachment . You've bridged ether1 and wlan1 and then made the bridge a DHCP server. You should junk export file.docx

Bridging the Groove can work when done right but it makes management of the Groove a lot more difficult as you move from one place to another.

If you tried the configuration posted in #18 and it failed upgrade your Groove to v6.44.3 and install it again. The configuration needs routterOS above v6.41. The configuration will provide you with the basic setup you need on a boat including a firewall and NAT.

Is Blueberry an AP you control and are using for testing? In the real world you won't always get an IP from any given AP.
 
TomHalfmoon
just joined
Posts: 2
Joined: Thu May 16, 2019 3:25 am

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Tue May 21, 2019 4:07 am

Hi Again
I was able to do the update to 6.44.3. Export file attached.
I can see my marine WIFI but it is not connecting. No idea as to why.

Thanks
Tom
You do not have the required permissions to view the files attached to this post.
 
plisken
Forum Guru
Forum Guru
Posts: 2388
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: Boat setup for GrooveA 52hpn and RB 951Ui-2HnD

Tue May 21, 2019 4:31 am

If you look at Tx / Rx CCQ you see a very bad wifi link. Signal to noise is very close together and this because there is a source of interference nearby. Maybe there are too many wifi users. I speak of experience that the UBNT bullet or Nanostation can withstand these sources of interference much better because they have better filters. Can you post a photo of the antenna connected to the Groove on the forum?

Who is online

Users browsing this forum: No registered users and 30 guests