Community discussions

MikroTik App
 
qudama
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 54
Joined: Mon Feb 24, 2014 2:26 am

Blocking Torrent in 6.27

Sun Mar 29, 2015 12:07 pm

Hello,
and i idea to block or limit torrent in 6.27?? :shock: :shock: :shock:
 
kivimart
newbie
Posts: 41
Joined: Thu Oct 10, 2013 3:06 pm

Re: Blocking Torrent in 6.27

Sun Mar 29, 2015 12:35 pm

I Use this in layer 7 protocol to identify Torrent then block rule in firewall forward chain.

/ip firewall layer7-protocol
add name=bittorrent regexp="^(\\x13bittorrent protocol|azver\\x01\$|get /scrape\
\\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet/|GET /data\\\
\?fid=)|d1:ad2:id20:|\\x08'7P\\)[RP]"
 
qudama
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 54
Joined: Mon Feb 24, 2014 2:26 am

Re: Blocking Torrent in 6.27

Sun Mar 29, 2015 4:11 pm

not works
 
kivimart
newbie
Posts: 41
Joined: Thu Oct 10, 2013 3:06 pm

Re: Blocking Torrent in 6.27

Sun Mar 29, 2015 5:40 pm

What torrent program are you using?
 
kivimart
newbie
Posts: 41
Joined: Thu Oct 10, 2013 3:06 pm

Re: Blocking Torrent in 6.27

Sun Mar 29, 2015 5:42 pm

 
qudama
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 54
Joined: Mon Feb 24, 2014 2:26 am

Re: Blocking Torrent in 6.27

Sun Mar 29, 2015 7:01 pm

i am using utorrent and yes i want block almost any torrent and the link you give me the code is error because there is no thing like /ip ff in mikrotik

please give me export code from your router and dont forget i am using 6.27 v
and if you have windows update block code please give it to me too.
 
User avatar
hossain2004a
Member Candidate
Member Candidate
Posts: 247
Joined: Mon Dec 22, 2014 7:34 pm
Location: Iran

Re: Blocking Torrent in 6.27

Sun Mar 29, 2015 9:03 pm

:IP/Firewall/Filter
I didn't work with "P2P" section. But maybe If you Drop all P2P, that should work, I don't know.

But It's about a year I'm using Leach services. It's funny. slow torrents become fast TCP 80 download :D
 
kivimart
newbie
Posts: 41
Joined: Thu Oct 10, 2013 3:06 pm

Re: Blocking Torrent in 6.27

Sun Mar 29, 2015 9:12 pm

This is user ohara ip firewall rules poasted in the other thread.

These rules block new torrents not the ones u already have started.

/ip firewall filter
add action=drop chain=forward comment="TORRENT No 1: Classic non security torrent" disabled=no p2p=all-p2p
add action=drop chain=forward comment="TORRENT No 2: block outgoing DHT" content=d1:ad2:id20: disabled=no dst-port=1025-65535 packet-size=95-190 protocol=udp
add action=drop chain=forward comment="TORRENT No 3: block outgoing TCP announce" content="info_hash=" disabled=no dst-port=2710,80 protocol=tcp
add action=drop chain=forward comment="TORRENT No 4: prohibits download .torrent files. " content="\r\nContent-Type: application/x-bittorrent" disabled=no protocol=tcp src-port=80
add action=drop chain=forward comment="TORRENT No 5: 6771 block Local Broadcast" content="\r\nInfohash:" disabled=no dst-port=6771 protocol=udp
 
qudama
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 54
Joined: Mon Feb 24, 2014 2:26 am

Re: Blocking Torrent in 6.27

Mon Mar 30, 2015 3:04 am

thanks alot my friend...
it now works2
 
sasha2002
just joined
Posts: 7
Joined: Thu Aug 06, 2015 10:05 am

Re: Blocking Torrent in 6.27

Thu Aug 06, 2015 10:07 am

Can anyone help with rules for v6.30.2 with NAT and fasttrack?

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], gourgovind, ingdaka, xvo and 51 guests