Community discussions

 
jmginer
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Tue Dec 11, 2012 4:56 am

ERROR in virtio disk driver in 6.31

Sun Aug 23, 2015 9:29 pm

Hello,
What's new in 6.31 (2015-Aug-14 15:42):
*) chr - added support for virtio disks
I tried to install RouterOS 6.31 on a VPS with:

- KVM virtualization
- Bus: virtio
- Type: qcow2

But not run. Not detect the disk.
Tested with RC6.32 and same result.

Image

Please, ensure the driver is correct.

Thanks.
 
marrold
Member
Member
Posts: 406
Joined: Wed Sep 04, 2013 10:45 am

Re: ERROR in virtio disk driver in 6.31

Sun Aug 23, 2015 10:03 pm

It works fine for me in QEMU / KVM. The supplied image is in .img format, I see you're using .qcow2. Did you convert it?
I'm a SIP / VoIP engineer. Feel free to ask questions...
 
jmginer
Member Candidate
Member Candidate
Topic Author
Posts: 115
Joined: Tue Dec 11, 2012 4:56 am

Re: ERROR in virtio disk driver in 6.31

Mon Aug 24, 2015 10:32 am

I'm getting this error on a RunAbove OpenStack service.
They don't provide me any option to upload a img.
I need to run my own ISO.
When they create the VPS, is created with virtio/qcow2 format, I can't edit this.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24206
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: ERROR in virtio disk driver in 6.31

Mon Aug 24, 2015 11:10 am

Only CHR supports it. Did you use the provided CHR image? It will not work from the regular ISO download.
http://forum.mikrotik.com/viewtopic.php?f=21&t=98981
No answer to your question? How to write posts

Who is online

Users browsing this forum: No registered users and 76 guests